Initial update does not get completed on MacOS Sonoma 14.1

Options
zaz0
zaz0 Posts: 4 Explorer

Noted that my installation has broken at some point (updated was not installing after update to Sonoma)

Reinstalled but initial update is not getting completed even after hours



Tagged:

Accepted Answer

  • ArthurVal
    ArthurVal Posts: 243 F-Secure Employee
    Answer ✓
    Options

    The fix is live for all products now. It will take effect in a couple of hours when the products start checking for updates and discovering fixes to be applied.

    Please let us know if if there are still issues later today. We'll take a look.

    Thanks!

    Best regards, Arthur

    Mac R&D Team

«1

Answers

  • PawełP
    PawełP Posts: 257 Moderator
    Options

    Hi @zaz0

    Thank you very much for your post and welcome to our forum community.

    To solve this problem run this command in Terminal on you Mac:

    sudo chmod 644 /Library/F-Secure/fssp/etc/subscription_map.txt

    The easiest way to open Terminal is from Spotlight search. Click on the small magnifying glass icon at the top-right corner of your Mac or press Command + Space keys at the same time to launch Spotlight. Then you can type in "Terminal" and double-click the appeared Terminal. app to open it.

    Restart the mac.

    If the problem persists despite this, please let me know.

    Have a nice day

    Pawel

    Making every digital moment secure, for everyone


  • zaz0
    zaz0 Posts: 4 Explorer
    Options

    Hi @PawełP

    And thank you for your reply.

    Unfortunatelly that didn't have any effect to the issue. It's still waiting the initial update to be completed.

  • Reichac
    Reichac Posts: 1 Observer
    Options

    same with my mac on Sonoma 14.1

  • Conor
    Conor Posts: 9 Explorer
    Options

    Same here. That file already had 644 as the access mask. So obviously that command would do nothing. (Have the same problem on Intel Macs and Apple silicon Macs. Sonoma 14.1)

  • Firmy
    Firmy Posts: 1,753 Community Manager
    Options

    Hello @zaz0 @Reichac @Conor

    Thank you for your comments.

    We recommend that you use the Uninstallation tool to remove the app, and then proceed to reinstall it. You can find instructions on how to use the Uninstallation tool in this link: How do I uninstall F-Secure products using the Uninstallation Tool for Mac? - F-Secure Community

    Once you've successfully removed the app using the tool, please refer to this link to reinstall it: Installing the product on your computer | Total | Latest | F-Secure User Guides

    Please share the results with us after completing these steps.

    Thank you, and have a great day.

  • zaz0
    zaz0 Posts: 4 Explorer
    Options

    @Firmy

    I have already tried uninstallation and reinstalling product and that does not have any effect to the issue.

  • Firmy
    Firmy Posts: 1,753 Community Manager
    Options

    Hello @zaz0

    Thank you for your reply.

    May I kindly ask if you have already tried uninstalling the app using our Uninstallation tool? If not, we recommend doing so for a clean reinstallation.

    We look forward to your response.

    Thank you, and have a great day.

  • R_M
    R_M Posts: 5 Explorer
    Options

    Same here!! MBP with Sonoma 14.1

    I have already used the uninstallation tool twice but without success and after that installed the product according the User Guide, but .. the issue remains.

  • zaz0
    zaz0 Posts: 4 Explorer
    Options

    @Firmy

    Already done that and now did that again. Not helping.

  • R_M
    R_M Posts: 5 Explorer
    Options

    addition: waiting for initial update version 19.3 (52927)

  • Conor
    Conor Posts: 9 Explorer
    Options

    @Firmy Like the others, I too have uninstalled the app and re-installed it. The problem still persists - it is still "waiting for the initial update to complete."

  • Firebones
    Firebones Posts: 8 Explorer
    Options

    Like all the rest of you I've come across the exactly the same Problem with mine, tried everything I was instructed to do but got the same reply uninstall it and reinstall it but it doesn't work with Sonoma I have had to go back to Ventura and it looks like I'll have to change Virus Security to something that is as I don't want to use Google/Windows plus the amount of problems of music Apps that have cost as much as a computer, I really hope they get around what seems to be a stumbling block, it is sad as I'm well used to F-Secure Total but I can't keep spending money that I can't afford.

  • PawełP
    PawełP Posts: 257 Moderator
    Options

    Hi @zaz0 @Reichac @Conor

    We need to study this problem closely to find a definitive solution.

    In a moment I will send you to your private forum inboxes a request to collect diagnostic data.

    We will be able to analyze this problem in detail.

    Have a nice day.

    Pawel

    Making every digital moment secure, for everyone


  • JelleJanssens
    JelleJanssens Posts: 5 Observer
    Options

    I've got the same issue here - but not an initial update.


    F-Secure Version 19.3 (52927)

    MacOS 14.1 Beta

  • Conor
    Conor Posts: 9 Explorer
    Options

    @PawełP I have a fsdiag.tar.gz - what am I supposed to do with it? There is no option in the support tools for submitting this to customer support. I can't see how to do this on the website either.

  • PawełP
    PawełP Posts: 257 Moderator
    Options

    Hi @Conor

    I sent you a private message on community forum.

    Please attach fsdiag file in response to this message.

    Have a nice day

    Pawel

    Making every digital moment secure, for everyone


  • Fritzz
    Fritzz Posts: 19 Enthusiast
    Options

    Experience the same issue: new install (19.3, 52927) on macOS 14.1, stuck on "waiting for initial update to complete".

    Adding @ArthurVal for visibility.

  • robvanvliet
    robvanvliet Posts: 1 New Member
    Options

    Same here: new install (19.3, 52927) on macOS 14.1, stuck on "waiting for initial update to complete".

  • PawełP
    PawełP Posts: 257 Moderator
    Options

    Hi

    I have good news.

    The problem has been recognized and R&D has now prepared a fix, which is being made available to all operators gradually.

    So all updates should be completed soon.

    When I receive new information on this I will share immediately. 

    Have a good day.

    Pawel

    Making every digital moment secure, for everyone


  • Conor
    Conor Posts: 9 Explorer
    Options

    Thanks, Paweł!

  • R_M
    R_M Posts: 5 Explorer
    Options

    It seems all works fine now, thanks !!

  • Fritzz
    Fritzz Posts: 19 Enthusiast
    Options

    The initial update after installation is now successful. But it seems that the database is not updating.

    When I open F-Secure -> question mark -> about, the database version stays the version of the initial update. A manual check for updates does not update the database version either.

    Latest database versions information: F-Secure Latest Database Updates

  • Firmy
    Firmy Posts: 1,753 Community Manager
    Options

    Hello @Fritzz @R_M

    Thank you for your feedback,

    Could you share us a screenshot of the database version shown? Also, have you tried to restart your Mac?

    Thank you.

  • Fritzz
    Fritzz Posts: 19 Enthusiast
    Options

    Hello @Firmy,

    Version: 19.3 (52927)

    Database version: 2023-11-01_18 (the version from the initial update)

    Done multiple restarts, no difference.

    Thanks!

  • R_M
    R_M Posts: 5 Explorer
    Options
  • Firmy
    Firmy Posts: 1,753 Community Manager
    Options

    Hello @Fritzz @R_M

    Thank you for your reply.

    @R_M, it seems you've received the new database update, and it appears to be working well for you.

    @Fritzz, there's a new update available today. Could you please give it another try? If the new update doesn't install successfully, consider uninstalling and reinstalling the app to see if the issue still persists.

    Please keep us posted on the results.

    Thank you, and I hope you have a great day!

  • Fritzz
    Fritzz Posts: 19 Enthusiast
    Options

    Database updates are now also successful.

    Thanks @Firmy, @PawełP & @ArthurVal for both fixes!

  • teos83
    teos83 Posts: 1 New Member
    Options

    Hello,

    seems I have the same problem