FS protection 17.3

martinkmartink Posts: 356 Path Finder

On my Android 6 device I have FS protection 17.3.

This morning it notified me that it has been updated.

On the lw things in fmilock screen "Your device is protected" message keeps flashing.

When I try to open it I get the message Unfortunately F-Secure has stopped. Report / OK.

 

If I click report I do nto see any results except that the same notification reappears. Did it get reported if F-S Protectio nis not working?

 

Is that as designed?

How do I get rid of those two things?

 

Apparently reboot got rid of the Your device is protectd message and the other message about new things in Family rules.

Ukko

Best Answer

  • UkkoUkko Posts: 2,997 Superuser
    Accepted Answer

    Hello,

     

    Just as my own feedback: my device (Android 8.1.0) with "manual update for applications" option.

    So, when I installed fresh update for FS Protection (Play Market) -> I received system's Crash notification about FS Protection (as with your experience) right after complete-step of update-installation.

    I did use "Report" -> five seconds later -> else one crash notification and so on.

     

    Then I tried to choose "Restart application" -> else one crash -> tried to choose "Restart application" else one time and switched to 'system information' from notification about "FS Protection too much battery usage" (and maybe "close application). Then crashes - stopped. But after manual try to open FS Protection application (or Safe Browser) ->> crash.

     

    After restart device -> manual try to launch FS Protection and still crash notification.

    There, also, splashes of "Your device is protected" (three probably; or more) when device is idle after boot up (or something else - like if additional events around).

     

    After turn off/turn on device -> still crashes. In general, even if I did not try to launch FS Protection.

     

    Thanks!

     

    // uninstall FS Protection and reinstall back -> it is possible to launch FS Protection and to receive welcome screen with terms.

    But some troubles else: with login screen page -> Privacy Policy URL is not possible to be opened. Screen is switched to "check your network connection and try later" (while all OK with network).

    Then it was possible to set up installation as main profile.

    But after first restart -> crash for FS Protection  and then normal work (before restart I did use it and Safe Browser; I did not choose Safe Browser as default one; and did not allow receiving SMS?! probably - there was 'circle' as potential notification by application -> after restart circle is not visible and FS Protection goes to crash or freeze at launch; but then switched to normal state, at least, after launch Safe Browser).

Comments

  • martinkmartink Posts: 356 Path Finder

    OK, thanks Ukko. I mark this as solved. That happened on the outskirts of the reception area and only once.

    Ukko
  • UkkoUkko Posts: 2,997 Superuser

    @martink wrote:

    OK, thanks Ukko. I mark this as solved. That happened on the outskirts of the reception area and only once.


    Hello,

     

    Maybe you should not. For example,

     

    -> there are no answers to your ask; it was only my own feedback (and experience with such trouble);

    -> with my experience: trouble is not sorted. I reinstalled it multiple times (later) with tries like "from first as kids profile" or "from first as main profile" -> and always there are 'background'-based (invisible?!) crashes or visible ones. But I did not report under beta-portal (maybe needed).

     

    Recent experience was about try with "from first as kids profile";

    Result was 'invisible' crashes (only sound of potential crash; but not visible ability to close/restart or report). Much trouble was with trying to check photos (Photo application by Google?) -> when I open it and try to open/look any photo or switch them -> on-going sound of crash (as it was with visible crash screen).

     

    Thanks!

  • UkkoUkko Posts: 2,997 Superuser

    Hello,

     

    Just like updates about my experience (after some days and tries with reinstallation):

     

    ->> Crashes maybe stopped;

    But first launch after restart device with troubles for launch FS Protection; For example, only after launch "Safe Browser" -> FS Protection is launched. BUT:

    ->> When I do use "product improvement data"-checkbox with "ON"-state: ability to report crash situation is visible. Recent experience was about crash at start device with further noted trouble with autolaunch FS Protection.

     

    Thanks!

    yeoldfart
  • yeoldfartyeoldfart Posts: 509 Superuser
    update without a glitch, smoth operation
This discussion has been closed.