Have to turn off Freedome to retrieve mail through Apple Mail

bookfan2 Posts: 2 New Member

I have been using F-Secure Freedome for several months without a problem. I have two Macs running OSX Yosemite, one iOS device, and one android device using Freedome. Within the last two weeks, I have noticed that I have to turn off Freedome on my Macs in order to retrieve my mail through Apple mail. I have checked settings and have them configured according to Apple specifications. This problem affects all of my email accounts. As soon as I turn off Freedome, all of the mail is retrieved suddenly without difficulty. When I resume Freedome, no mail comes in. 

I have researched on the Community Forum and found the instructions regarding outgoing email (I have no problems since reviewing and fixing the settings with outgoing mail.). I see no instances of difficulty with incoming email through Apple Mail.

I have no problems on my iOS and android devices. Freedome otherwise seems to be working perfectly on all devices.

Has anyone had a similar problem and have any suggestions to fix this difficulty?



  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi bookfan2,


    To further check on this post, may I know what mail service are you using with Apple mail?


    Could you try to disable the Tracking protection and Browsing protection in Freedome (one at a time) to see if you are able to retrieve mails through Apple mail?

  • bookfan2
    bookfan2 Posts: 2 New Member

    I can't seem to establish a pattern for the failure to retrieve mail. It affects all my email accounts (gmail, yahoo, etc.). When Freedome first launches, Apple Mail seems to retrieve the messages. Then, at some point, it seems to block everything, but I can not consistently determine when or why this occurs. I tried turning off tracking and browser protection separately, but can not tell if there is a difference. As long as mail is not completely blocked, Apple Mail will retrieve with tracking on/browsing off or tracking off/browsing on. Once the mail is blocked completely, I have to turn Freedome completely off by clicking on the top (target shaped) Freedome tab to get the Apple Mail to retrieve mail again. It takes a minute or two, and then all the accounts come back. This is what I do when I see the triangle with an exclamation mark in the middle next to the account. At times, I may not see an indication of the account not functioning, but when I turn Freedome completely off, a large number of emails are retrieved!

  • 56kbps
    56kbps Posts: 5 Observer

    Gmail/Google might be blacklisting the VPN ip addresses. Try logging on to Gmail using a browser (with your  VPN enabled). See if you get a security prompt asking you to verify yourself. My guess: Gmail is not allowing your email client access because you haven't confirmed your identity to Google. Google might think your email client is a browser, and that you are unable to answer your security questions for whatever reason. Give that a try. I have no problems with Apple mail, but I'm constantly verifying myself through my browser since I'm a youtube whore. My guess is that once you verify yourself using a specific IP address you get whitelisted. I have never experienced this problem, but that might be because Google's algorithms flagged me as a "traveler." Who knows. 

  • Rick_Harris
    Rick_Harris Posts: 1 New Member

    I  have the same problem with Apple Mail. I can retrieve mail through iCloud, but that doesn't enable notifications. Has anyone resolved the problem?

  • Felice
    Felice Posts: 1 New Member

    I have the same problem with Apple Mail! No issues to log-in to Gmail on my browser, but Apple Mail doesn't receive the Gmails. Another Exchange server works perfectly. I switched off Browser Protection and Tracking Protection, both doesn't solve the problem. Maybe someone from F-Secure can help with that issue?

  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi and welcome to our Community, @Felice!


    Please open a support ticket with the Freedome logs in order to investigate this issue better.

  • revenger
    revenger Posts: 1 New Member

    Just bought 1 year plan and have exactly same problem;( Need to turn off freedome in order to use mail.... works in browser and ios devices.

  • Dropy
    Dropy Posts: 1 New Member


    I have the same issue here, any way to solve it ?


  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi @Dropy,


    Could you check this article and see if it helps? If not, please get in touch with our support team via phone/chat to troubleshoot further.

  • 92Bubu
    92Bubu Posts: 5 New Member

    Same issue on my side but with Hotmail. 


    Did you get finally a fix?

This discussion has been closed.
Product & Pricing Info