Fatal Error Data required to run Freedome is missing or corrupted

Hello,

 

I wonder what’s up with Freedome as it stopped working a couple of days ago. All I see now is the popup window saying “Fatal Error Data required to run Freedome is missing or corrupted. Please reinstall the software.” I have not done anything out of the ordinary with/to my system other than upgrading Freedome whenever it has notified my about a new version.

 

Okay then, I downloaded the latest version (1.0.2246.0) from F-Secure’s website and tried reinstalling it but kept getting the same popup window over and over again.

I tried downgrading to 1.0.1842.0 but that did not help either.

 

The only thing that I haven’t tried yet is completely uninstalling and then installing from scratch but I am hesitant to do that since to my understanding that would cause me to lose the license.

 

Could you please help? This is really annoying to say the least.

I am running Windows 7 64 bit SP1.

 

Averell

Accepted Answer

Comments

  • Okay, I gave it a try. Uninstalled, downloaded a fresh version from your site and installed that.

    Did not see that pop-up window appearing any more and the product showed me that I was given 14 days trial period.
    I punched in my key code and to my somewhat big surprise it was accepted. I had expected Freedome to complain about license quota having been used up but it did not do that. Cool!

    So, the problem appears to have disappeared. I have been using the newly installed Freedome only for one day so it may be too soon to tell but so far so good.

    Thanks for the tip.

    Averell
  • LakshLaksh Posts: 4,444 Community Manager

    Hi Averell,

     

    You are welcome! Thanks for your update on the issue and glad to know it has been installed successfully now.

  • MirelaMirela Posts: 2

    I have the same error message and have had it for a month. Doesn't help to reinstall. Network settings seem OK. Running Windows 7.

  • LakshLaksh Posts: 4,444 Community Manager

    Hi @Mirela, if the issue persists even after a reinstallation, kindly open a support request with your Freedome logs for analysis.

  • yakalexyakalex Posts: 7

    Hi,

    Strange, I got the same error today. Thought I had to uninstall and install again, but I tried just in case to launch freedome from the desk with the icon --> it started without any pb. Just in case, I've done a diag and kept the files. I can send them to you if you want ? OS Microsoft 8 and Firefox as browser.

     

    While I was writing this post, freedome asked for an update. Maybe linked ?

     

    Just in case, could you confirm that if freedome or microsoft crash and we have to instal freedome again, the current license is still available or we can just ask for a reset ? (read on the FAQ, hope I have well understood). I have the 3 products license.

     

    Regards,

  • LakshLaksh Posts: 4,444 Community Manager

    Hi  yakalex,

     

    Did the reinstallation solve your issue? Is Freedome working fine now again? If the error message comes again, I would recommend to contact our support via a support request with the logs. Please do upgrade the product to the latest version if there is an upgrade pop-up.

     

    Regarding the license query, we do have the license transfer option with Freedome. This article explains it in detail.

  • yakalexyakalex Posts: 7

    Hi Laksh,

     

    I didn't need to reinstal. I just started the app from the desktop icon ignoring the warning message and it worked. A few minutes later I got an update message which I have accepted.

     

    It seems to work perfectly. In my case, the error message was a "fake" one. Except the app didn't start automatically in the first case.

     

    Thanks for the rest. Remember: if you want the diag, I can send it to you or anyone else for expertise purpose.

  • LakshLaksh Posts: 4,444 Community Manager

    Thanks for updating me, @yakalex. Glad to know all is well now.

This discussion has been closed.