Driver Installation Error

Whenever I turn my laptop on and activate Freedome, I always get this message. After a reboot it works fine but it's very inconvienient having to start my device twice each time I need to use it. Is there any way to fix this?


2015-11-16 (4).png


  • LakshLaksh Posts: 4,444 Community Manager

    Hi Nevare88,


    May I know what is the version of Freedome installed on your machine? What is the OS of your machine as well?


    Was there any upgrade which happened with Freedome recently? Since when do you start seeing this error?

  • ivoimivoim Posts: 8



    I have the same problem. My version of FSecure Freedom is 1.0.2246.0,

    My version of windows is build 10.586.3

    I have already reinstalled Freedom but the problem returns.

    My impression is that the problem started with installing my current windows 10 version.

  • I have the samae problem and I don´t know what to do !!

  • I also have the "driver installation error"

    My version of FSecure Freedome is 1.0.2246.0,
    My windows version is '1511' (=build 10.586.3)
    I have already reinstalled Freedome several times but the problem returns.
    Now when I enter my Freedome code it gives me an error
    "maximum number of installations..."
    My subscription (3 devices) includes support in English via F-Secure Community

    Please fix this, Please fix my subscription asap


    to Laksh (community manager): I have sent you my order reference number via 'private message'

  • LakshLaksh Posts: 4,444 Community Manager

    Hello Everyone,


    Apologies for the delayed response on this issue. We are aware of this issue with Freedome and Windows 10. Our RND team in troubleshooting further on this issue to analyze further. However, in order to gather more information on this, please open a support ticket from here and provide all the details of the issue.

  • ivoimivoim Posts: 8



    I have opened a support ticket and got a reply from the customer service engineer. I was advised to following the instructions as indicated in:

    (This site refers to a VPN initialization error).


    However this did not solve my problem which relates to a driver installation error. In my case the problem might be related to windows power management. Each time my laptop is put into the sleeping mode the driver issue seems to be emerging. Does this makes sense to anyone?



  • @Scholar
    Same problem her on a desktop.
    When it emerges from sleep mode I get a 'driver installation error' message
    have opened a support ticket, but no response.
    + What will F-secure do about my subscription issue?
    (="maximum number of installations..." message because of several freedome reinstalls following the 'driver installation error' message)
    Will my subscription be extended?
  • LakshLaksh Posts: 4,444 Community Manager

    Hi tballege,


    Our support team should be able to look into your ticket and assist further with the upgrade issue and also the license issue. I did highlight your post to the support team so that they are aware of this and will reply further with the case.

  • ivoimivoim Posts: 8



    What worked so far is that under Power Management I changed all the power options from "Sleep" to "Hibernate". It makes the laptop slower to come back up but at least I don't need to do a full restart. So far I do not experience problems any more with the Freedom TAP driver.


    Kind regards.




  • Hi, I'll just chime in since I am experiencing the same issue.


    It only occurs upon restarting the computer from hibernation mode, and only if Freedome was connected when the computer entered hibernation mode.


    If I disconnect Freedome (without terminating it) before entering hibernation, everything is fine on restart.


    Win 8.1 / Freedome 1.0.2246.0





  • I have experienced the same problem - Windows 8.1.  I read the series of posts with astonishment since it seems that the problem has persisted since March 2014.


    F-Secure need to be reminded that they have a statutory duty to supply digital content that is fit for purpose (Consumer Rights Act 2015 Section 35 (3)) .  Their failure to date to resolve the problem constitutes a breach of their statutory duties, and it is arguable that all the disatisfied people who have posted, and any others who have not but experience the same problem, are at the least entitled to a full refund from F-Secure.


    Chris Davis

  • ronzronz Posts: 11

    I am having the same problem in Windows 10 Freedome ver 1.0.2246.0. Happens when I start up my computer from any state, haven't tried shutting down Freedome first but I will try that. For me the problem first appeared after a Freedome update which apparently happened on November 12. Before that it was fine.

  • ronzronz Posts: 11

    OK, I tried just turning off protection on Freedome before shutting down or letting the computer go into sleep mode and that prevented this from occurring. If I just shutdown the comuter without turning protection off I still get the Driver Installation Error on start up.

  • ivoimivoim Posts: 8

    Hello Ronz,


    Thanks for the feedback. Did you also try to stop the sleep mode and change it to hibernate? In my case this solve the problem (so far?).


    Search for energy management (e.g. richt click on the battery symbol in the systems tray), go to the energy scheme you are operating with, choose advanced energy settings, go to sleep mode, set both settings in sleep mode to "never", next go to hibernate and change to settings to e.g. 15 minutes (battery) and 25 minutes, click OK.


    Hope this helps.

  • I too have the same problem Using Windows 7, 64 bit and Freedome version 1.0.2246.0 .
  • ronzronz Posts: 11

    I don't seem to have a hibernate option orelse it is buried pretty deeply. I'm using Windows 10 Home.

  • ivoimivoim Posts: 8

    Hello Ronz,


    1. Go to control panel, next to all control panel items, next to power options.

    2. Select to energy plan you are operating with and click on change plan settings

    3. Click on change advanced power settings

    4. In the open box click on the + of sleep, then 4 options open

    5. Click on the first "sleep" and change both battery and plugged in settings to "never"

    5. In the same open box as in point 4, click on the + of hibernate, again the same 4 options open

    6. Click on the third "hibernate" and change both battery and plugged in settings to e.g. respectively 15 and 25 minutes

    7. Click apply and next OK

    8. Repeat step 1

    9. Click on the left on choose what the power buttons do

    10. Next you will see options for the power and lid buttons. Put all settings to e.g. hibernatie, BUT AVOID the sleep setting and click on save changes.


    That is it!



  • ronzronz Posts: 11

    Thanks for posting those detailed instructions so that others may follow as well. So far that seems to be working fine!

  • Like others I too thought this was related to sleeping as I would put my Windows 7 machine to sleep with the VPN active and connected. But, today I had the problem and I had not put the computer to sleep. I had disconnected but left the software running and walked away for a while. I came back to the driver installation error. Freedome version 1.0.2246.0
  • ivoimivoim Posts: 8

    Hi Michael2,


    I am working with a windows 10 machine so I am not sure whether or not my preliminary solution works for a windows 7 machine. You mentioned you did not put your computer to sleep and run away for a while. Are you aware that - depending on your settings - your computer puts itself to sleep automatically?



  • Hi,
    downloaded/installed new Freedome version and put the pc to sleep. Seems to work without error message. Fellow 'scholars' please confirm...
  • ivoimivoim Posts: 8

    I can confirm your findings. I installed Freedom 1.0. 2352.0 and indeed no driver installation errors on my windows 10 laptop. Sleep mode does not to seem to be a problem anymore.





  • Yes, I am aware of this, but thank you. Another bad thing about Freedome is that you can't tell it to check for updates. You just have wait until it feels like tell you about it. Really bad desgin. I could uninstall completely, and then re-install from scratch, I suppose ...   

  • ronzronz Posts: 11
    So far the new update looks good, no more errors. I wouldn't have know about the update if it wasn't posted here. Even looking at the downloads, I can't tell what version number is being offered.
This discussion has been closed.