Browsing Protection is not working on Google Search Result on Edge / Chrome

am_kt_hk
am_kt_hk Posts: 1 New Member

Hello there,

I observed that Browsing Protection is not working on Google Search Results, it happens since yesterday night (27/10/2023) on both of my PC and Laptop while F-Secure Total installed.

All browsers and FS Total are up-to-current, resinstalling the plug-ins nor browser fresh insllation cannnot solve the problem.

While Firefox is working well, and same issue are not hapending on MS Bing on 3 browsers, could F-secure engineers please check? Many thanks

Cheers,

KF

--

Figure 01: Edge result - only sub pages are not rated

Figure 02: Chrome result - only sub pages are not rated

Figure 03: Firefox - all main and sub pages works ok

Accepted Answer

Answers

  • Ukko
    Ukko Posts: 3,617 Superuser

    Hello,

    Over the past weeks, I have encountered this or a similar situation some times with my beta installation. But, in my experience, after some time or restarting the browser, everything was fixed. That is, it was of some strange and incomprehensible state. It’s not entirely clear whether it has anything to do with Google's design or not. I actually didn't try to check this with Bing, Yahoo or DuckDuckGo at the time the problem occurred.

    What is version of Browsing Protection extension in your browsers (Edge, Chrome.. Firefox is likely another build)?

    Are you still able to reproduce the problem?

    Thanks!

This discussion has been closed.
Pricing & Product Info