F-Secure app (version 19.1) on Windows 10, can't log in

Silvanis
Silvanis Posts: 2 Observer

I have the F-Secure app installed on my laptop running Windows 10. I haven't used the computer for a few weeks, and today I found I'd suddenly been logged out of the app and can't log back in. I keep getting the error message: "Sorry! Could not connect. This could be due to our servers being busy or our awesome technicians are making improvements to them. Please try again in a few minutes." I've waited and tried again, but to no avail. All that happens is that I get an email about a new login attempt.


What could be causing this? I've had a license tied to the laptop since 2017(!), so that shouldn't be the culprit, and the last time I used it the app worked fine. I did install a Windows update then, but it didn't seem to affect F-Secure at that time. I've checked that the licenses are unchanged via the F-Secure app on my phone. The app updated itself the last time I used the laptop (to version 19.1) in August, but that didn't seem to affect my login status at the time either.

Tagged:

Accepted Answer

Answers