Browsing protection by F-Secure does not work properly

Diederik
Diederik Posts: 2 New Member

Since 2022-02-28 I have installed F-Secure Save on my computer..

In addition, I use "Browser protection by F-Secure" for Firefox.

With Firefox I am experiencing two problems since I installed the "Browser protection by F-Secure".

 1. Firefox no longer loads the website "ello.co".

    To my knowledge there is no reason to do so.

 2. Some websites including for example this website are not loaded at once.

     Only after pressing the button "refresh the current page" one or more times will the page will load.

What could be going on here?


On my computer I have

F-Secore Save version 18.3

Windows version   21H2 build 19044.1645

Firefox version  : 90.0.1 (64 bits)

 

Regards,

Diederik

Accepted Answer

  • Firmy
    Firmy Posts: 70 Moderator
    Answer ✓

    Hi @Diederik

    Welcome to our Community page. Thank you for your post.

    I tried to reproduce the issue on my end, however, I am able to load the Community page without any issue. And after reinstalling browsing protection by Firefox, I found the issue is resolved for ello. co.

    There is the latest version of Firefox, which is 99.0.1. Kindly update the version of your Firefox.

    1. Select the 3 bars at the top right hand side of Chrome
    2. Click on Help
    3. Click on About Firefox

    After installing the updates on Firefox, you may uninstall and reinstall Browsing Protection by F-Secure.

    1. Uninstall Browsing Protection by F-Secure
      1. Click on the 3 bars at the top right hand side of Chrome
      2. Click on add-ons and themes
      3. Click on Extension
      4. Find Browsing Protection by F-Secure
      5. Select the 3 dots at Browsing Protection by F-Secure
      6. Click on Remove
    2. Reinstall Browsing Protection by F-Secure
      1. Open F-Secure SAFE program
      2. Go to Secure Browsing & Banking
      3. Scroll down to the Browser Extensions section
      4. Click on Install Firefox extension
      5. Restart Firefox

    Kindly let me know if this helps.

    Thank you and stay safe.

    Jaims

Answers

  • Diederik
    Diederik Posts: 2 New Member

    Hi @Firmy,

    Sorry, I'm already using version 99.0.1, didn't mention it correctly!

    As for loading the "ello.co" website, I just found out that it's probably because of the Firefox "Always use private browsing mode" option. So if I have it enabled, which I have by default, the "ello.co" site won't load, otherwise it will.

    So it is most likely not due to F-Secure's browser security!

    The strange thing stays that in the past I disabled F-Secure's browser protection and then loaded the "ello.co" site fine....

Pricing & Product Info