Browsing Protection cannot be installed, reported as causing serious problems

Torspo1600
Torspo1600 Posts: 12 Explorer
edited January 31 in F-Secure Internet Security

All of a sudden F-Secure SAFE prompted me to take action. The problem stated by SAFE was that I need to configure the Mozilla Firefox extension to protect my browsing.

I had already configured the extension a long time ago, and when I decided to reconfigure by clicking Configure, Firefox displays the message "Browsing Protection by F-Secure cannot be installed, since it has been reported as causing serious stability or data security problems".

This is unusual, could you please check?

TimaeusOlli_VmrxfsecJoni91kjhgfdmlieberNiepppwestuUesomatDouglas_Anthony

Accepted Answers

Answers

  • Arjan
    Arjan Posts: 1 New Member

    I'm having the same issue with the Firefox extension. The warning message refers to this URL:

    https://addons.mozilla.org/en-US/firefox/blocked-addon/[email protected]/3.0.27/

    Torspo1600kjhgfdwestu
  • Olli_V
    Olli_V Posts: 1 Observer

    I have this problem as well, it seems to have started today. F-Secure SAFE is prompting me to set up Firefox Extension, but I am unable to enable it (it was already installed) since Mozilla has apparently flagged the extension as having security of stability issues.

    Clicking for more information on the add-on settings page leads to an explanation page (https://addons.mozilla.org/en-US/firefox/blocked-addon/[email protected]/3.0.27/) that has further information:

    "This add-on violates Mozilla's Add-on Policies.

    This add-on violates Mozilla's add-on policies by executing remote code and insufficient user data handling and protections."

    F-Secure might want to look into this.

    Torspo1600Joni91kjhgfd
  • Timaeus
    Timaeus Posts: 12 Enthusiast

    You are not the only one, I suddenly started having the same problem just now. I've never had the issue before.

    I don't think either Firefox or F-secure updated, but out of the blue F-secure alerted prompting me to set up the extension, but trying to do so gives the error: "Browsing Protection by f-secure could not be installed because it has a high risk of causing stability or security problems".


    Firefox 98.0.1 (64-bit), Windows 10.

    (I'm using an ISP-provided version of SAFE.)

    Torspo1600kjhgfd
  • mrxfsec
    mrxfsec Posts: 3 Observer

    Just reported same on forum here, I hadn't even tried to reconfigure mine. Mozilla must have just decided to start blocking.

    Torspo1600kjhgfd
  • Joni91
    Joni91 Posts: 7 Observer

    I got that too. It appears that Mozilla blocked the extension because they think it violates Mozilla's add-on policies.

    Quotes from about:addons F-secure extension's more information button.

    "This add-on violates Mozilla's add-on policies."

    "This add-on violates Mozilla's add-on policies by executing remote code and insufficient user data handling and protections."

    kjhgfdTorspo1600
  • anorthernangle
    anorthernangle Posts: 2 Observer

    I, too, now have the same problem.

    From the Mozilla Firefox About window

    Firefox is up to date

    98.0.1 (64-bit)

    From the F-Secure SAFE window

    2021-12-28 F-Secure SAFE was updated to version 18.2

    kjhgfdTorspo1600
  • Agraaf
    Agraaf Posts: 1 New Member

    I'm having the same problem.

    Also firefox and f-secure up to date.

  • Ronnie74
    Ronnie74 Posts: 2 New Member

    i am having the same problem when using the latest firefox, F-secure should come up with a fix a.s.a.p i hope.

  • Uesomat
    Uesomat Posts: 3 New Member

    Same problem here as of today

  • UmarA
    UmarA Posts: 1 New Member

    Hello. I am experiencing the same issue as the other contributors above.

    This means I cannot do secure online banking until this problem is resolved.

    Do F-Secure devs have an idea what has suddenly caused this Firefox behaviour?

  • Douglas_Anthony
    Douglas_Anthony Posts: 1 New Member

    Ditto Hope this problem has reached the ears of F-Secure and a fix is soon found

  • StefanL38
    StefanL38 Posts: 8 Observer

    I have the same problem.

    F-Secure-Team: WHY DID YOU NOT YET ANSWER TO THIS PROBLEM???

    best regards Stefan

  • Jaims
    Jaims Posts: 860 Former F-Secure Employee
    edited March 2022

    Hi @Torspo1600 @Arjan @Olli_V @Timaeus @mrxfsec @Joni91 @anorthernangle @Agraaf @Ronnie74 @Uesomat @UmarA @Douglas_Anthony

    We are aware of this issue on the Windows version of our consumer and corporate EPP products.

    We are currently working with Mozilla to solve this issue. Meanwhile, we recommend that you use either Microsoft Edge or Google Chrome browser until the issue has been fixed.

    We already published a KB article about this issue and you can read more here https://community.f-secure.com/safe-en/kb/articles/9259

    You can subscribe to our Status page to get notified on incident reports and when they get resolved.

    https://status.f-secure.com/

    Thanks for your patience and understanding.

    ArjanBeeceeUkko
  • Chris_Eagle
    Chris_Eagle Posts: 2 New Member

    Hello, do you know when this issue will be fixed ?

    Thank you.

  • Nihilissimis
    Nihilissimis Posts: 1 New Member

    Sorry @Jaims e.a. at F-Secure, but your anwer is highly unsatisfying. No mention as to WHY you where blocked, i.e. which policy was breached. As I read through the policies, none of them seem very likely other than the existance of an 'unexpected feature'. If this is the case, that makes me VERY nervous, since your add-on is in all practicality a man-in-the-middle for everything and anything. including my internet banking..

    Explain or loose trust forever.

    Chris_Eagle
This discussion has been closed.
Pricing & Product Info