What is the technical reason why enabling Freedome causes huge network bandwidth loss

samijtsamijt Posts: 2 New Member
edited August 20 in F-Secure FREEDOME

Hi,

Finally, I'm starting to be frustrated to Freedome as it is eating the network bandwidth. This has been the case since I've started to use it in late 2017. But now, the problem is even more disturbing as I upgraded my 350 Mbps connection to 1 Gbps one. Here are the measurement result from speedtest.net:

Disabled F-Secure Freedome:

Ping: 2 ms

Download: 845.12 Mbps

Upload: 94.83 Mbps

Link to results: https://www.speedtest.net/result/9946344738

Enabled F-Secure Freedome:

Ping: 16 ms

Download: 64.74 Mbps

Upload: 32.44 Mbps

Link to results: https://www.speedtest.net/result/9946352710


I've tested this with 3 different computers which all uses wired ethernet connection. The results are inline with above.

I've seen this same question in this forum, but not really a deep technical answer why this happens. I've read that MTU size might cause packet fragmentation with VPN, but what is your expectations that what is the performance loss if that happens with Freedome? What is actually suggested MTU packet size when Freedome is enabled? Any other ideas to try?

Answers

  • SethuSethu Posts: 644 Moderator

    Hi @samijt

    On Windows, Mac and Android, FREEDOME uses OpenVPN to secure the network traffic. Because of the technical limitations in OpenVPN, the maximum throughput will be around 150 Mbit/s, provided that the network connection allows this fast connectivity. On Apple iOS devices, FREEDOME uses the built-in IPSec VPN instead of OpenVPN, and is not tied to the limitations of OpenVPN. This allows faster throughput, again provided that the network connection is fast enough.

    Most of the time, the slow speed issue can be fixed using the simple basic troubleshooting techniques, like clearing the DNS cache or best try re-installing the Freedome. Sometimes bad results will be cached and therefore need to be cleared from the cache in order for you to communicate with the host correctly. Please also refer the steps from this KB article to find more basic troubleshoot steps.

  • JOnesJOnes Posts: 264 Active Engager
    • Still dreadful(25.8.2020 1925-30 EET) low bandwidth test results(https://fast.com/fi/#, even after those workarounds above) with "Espoo"-platform(windows,android).Again "Stockholm"-platform is more effective.


  • samijtsamijt Posts: 2 New Member

    Hi,

    I've done all the bulletin tricks etc. but the result is the same: On 1 Gbit/s connection you will get less than 100 Mbit/s speed with Freedome. So, I know that when my subscription ends, I will check alternatives for home internet security.

    <offtopic>

    It is nice to have almost invisible actions on internet, but eating the bandwidth this much is not ok. I'm almost willing to think if there is something related going on with movie, music or streaming companies here.... Anyhow, Freedome is no-go when I will renew my license next unless some changes/improvements will happen.

    </offtopic>

  • SethuSethu Posts: 644 Moderator

    Hi @samijt ,

    Does it happens on one particular virtual location? have you tried to change the different virtual location that closest to you? i.e If there are many users on the same server to which you are connected then you can face a slow speed. Therefore, you should switch the servers in order to find the one which has relatively less load. 

    Could you also try the following steps and let me know the situation?

    • Resetting your network router.
    • Try FREEDOME with a different network connection to make sure it is not a router issue.
    • Try to temporarily disable any antivirus that you have running (for example Panda Security has been known to cause slowness in the FREEDOME VPN connection).
    • Reinstall FREEDOME.
    • Select different virtual location
    • If you are using mobile, try connect with mobile data i.e 4g and turn Freedome ON to ensure the connection issue with Freedome on Network router.


Sign In or Register to comment.