Mobile security and phone not starting up


Mobile security and phone not starting up


I bought mobile security for my phone 6 months ago. Everything was working fine up until 2 weeks ago.


My phone is Samsung Galaxy S2 Plus.


My phone suddenly refused to start up, only thing I got was that Samsung logo and even if I waited 5-10 minutes, nothing happened. Every time I tried to start up my phone I had to try 10-15 times until it finally started.


So.... I restored the factory settings and updated everything, no help.


Then I had an idea, I uninstalled F-Secure mobile security and tried. Now it seems to start up again.


I wonder.... could there be some bug etc. on mobile security that actually does this, or is this just a huge coincidence? Anybody else had similar issues?



If F-S is the culprit, I wonder is there anything I can do about it except leave it uninstalled?


Thank you.



Re: Mobile security and phone not starting up

I found an (maybe) related old thread that suggests clearing the cache in Application Manager.


Or perhaps better you could try a separe product:  

CCleaner is truly great on computers, but I have no experience with the mobile version.


Another thing to test is to re-install Mobile Security after uninstalling it. Just to see if perhaps that makes any difference


Re: Mobile security and phone not starting up

Hi, thank you.


I tried that, no help. Also re-installed it, no help.


As soon as I uninstall it, everything works OK.


I also tried AVG, no problems.


Well, at least now I know that my phone is not faulty, kind of a bummer though that I can't use F-S which I purchased originally.


Former F-Secure Employee

Re: Mobile security and phone not starting up

Hi, I would like to investigate this further. Can you create a support ticket and send me the ticket number as a private message?

Best Regards

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.