iOS 11.0 and WiFi

Since the iOS 11.0 update, WiFi disturbs with Freedome VPN, "No Internet connection". With VPN off, no problem. How to solve this problem?

Best Answer

Answers

  • UkkoUkko Posts: 2,939

    @OldSailor wrote:

    Since the iOS 11.0 update, WiFi disturbs with Freedome VPN, "No Internet connection". With VPN off, no problem. How to solve this problem?


    Hello,

     

    Under community recently was some topics/replies with potential fix (or workaround concerned IKEv1/2 setting) - which can be valid for your experience too:

    https://community.f-secure.com/t5/F-Secure/Re-F-Secure-FREEDOME/m-p/99206

    https://community.f-secure.com/t5/F-Secure/Freedom-not-working-anymore/m-p/97965

     

    Do you able to re-check such meanings (if possible)?

     

    Thanks!

  • Hello OldSailor⛵

    There has been in media news about Apple iOS11, this new version has caused many problems. Problems with Wifi and bluetooth-connection.
    I found a checking list in internet:
    Settings > general > about tab > click applications > list of apps, that might not yet be compatible with the iOS11

    For your information
    Näsäviisas

  • After changing from an iPhone SE with iOS 11.1 to an iPhone 7 with the same version I started losing connection to my home Wi-Fi when I turned Freedome on. The VPN switch in setting was flicking back and forth like mad and in the app interface it was trying to connect. This also caused the phone to drop the Wi-Fi connection and only display the cellular connection, even though I was connected to the SSID when looking in the phone settings.

     

    Like mentioned here above, it was solved by selecting IKEv1 in the app settings. But this I see as a compromise solution as there are several benefits to IKEv2 over IKEv1.

    I'm keen to know what is causing the problem and how to solve it so that I can return to using IKEv2.

     

    Current installed Freedome version: 2.7.2.5505

  • UkkoUkko Posts: 2,939

    venaja wrote:

    After changing from an iPhone SE with iOS 11.1 to an iPhone 7 with the same version I started losing connection to my home Wi-Fi when I turned Freedome on. The VPN switch in setting was flicking back and forth like mad and in the app interface it was trying to connect. This also caused the phone to drop the Wi-Fi connection and only display the cellular connection, even though I was connected to the SSID when looking in the phone settings.

     

    Like mentioned here above, it was solved by selecting IKEv1 in the app settings. But this I see as a compromise solution as there are several benefits to IKEv2 over IKEv1.

    I'm keen to know what is causing the problem and how to solve it so that I can return to using IKEv2.

     

    Current installed Freedome version: 2.7.2.5505


    Hello,

     

    This knowledgebase article about 'full' trouble with connectivity:

    https://community.f-secure.com/t5/F-Secure/Freedome-on-iOS-doesn-t-connect/ta-p/98079

     

    with meanings that IKEv2-based trouble can be related with devices like routers/modems or solutions like firewalls (and so on). I'm not sure that your experience about article's meanings (most likely, yes -> but anyway). If this trouble is not based on your configuration of devices (or settings of solutions) -> maybe good to receive normal official response from F-Secure.

    I able to think that possible to re-check it by search information concerned your modems/routers (or other layers) OR with try to use Freedome/iOS with another Wi-Fi network (where it should work).

     

    Thanks!

This discussion has been closed.