Freedom (v2.6.6.5240) unable to connect to VPN on Vodafone network using IOS v10.2.1

I haven't used Freedom VPN for a few months following my IOS update to the version above but my VPN fails to connect at the moment.  I have tried following the guides to:


remove the VPN configuration through settings and reapplying - Failed to address issue


Removed the Application and reinstalled via the App Store - Failed to address issue


I am seeking guidance on next steps to resolve the issue as my subscription is up fro renewall.


  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi RobWalton,


    Welcome to our Community!

    Since you have mentioned the connection fails in Vodafone network, have you tried to turn on Freedome in any other Wi-Fi or data network?


    Do you see any error message in Freedome when you try to connect it/turn it on? Does it happen with all the locations?

  • Its an interesting observation which I noted yesterday myself when troubleshooting.  The WiFi connection whch I'm on (and working) actually disconnects me and forces the handset to go via mobile Data (4G in this instance).


    The screen shows a continual circulating 'Checking' box that eventually times out after about 5 minutes with a failure message that the VPN could not be connected\established.


    When I look in Settings/About/VPN - I can see the F-Secure Freedom entry which is set as follows:


    Type: IPSec


    Connect On Deman: On

    Status: Not Connected



  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi RobWalton,


    I found a similar post regarding this issue here. The description in the previous post relates to your post and it is seen that the actual issue lies on the OS.


    However, could you also check this KB article and see if this helps?



  • I have tried to follow the steps and although the VPN now informas me its connected via the App interface, the VPN when viewed through the Settings\General\VPN configuration shows as connecting..... and no Internet connected apps function such as Safari which i tested.


    It may be that Apple's latest update to IOS when handling IPSec has put a nail in the coffin of this application for me.  I need to cancel my subscription right now as it is set to renew at the beginning of April 2017 (a few days from now).  If this issue gets resolved then please contact me and I will look to come back to the application but as this does not offer me the protection I want now I need to shop around.


    Thanks for support team.

  • D-Fens2
    D-Fens2 Posts: 78

    F-Secure should really consider changing the protocoll of the iOS Version :/

  • Well it's gotta work with the product or recommended IOS or I simply can't use it and this costs the business money in lost revenue. I've had to cancel as I won't pay for something that doesn't work. I like the product and will be back once it's fixed. 

  • planet
    planet Posts: 3

    Freedome VPN has been working fine on 10.2.1 and continues to work fine on 10.3 (released publicly today) for me, both Wi-Fi and 3G/4G.


    Sounds like it's too late, but I would've suggested to reset your iOS network settings (Settings > General > Reset > Reset Network Settings) before reinstalling the app to give all Mobile/Wi-Fi/VPN connections a fresh start again, as you were having issues with both 4G and Wi-Fi.


    It may also be a specific issue with your network carrier and wireless gateway/router blocking VPN connections, or your iOS device is really confused with network settings (why I suggest resetting network settings above).

  • D-Fens2
    D-Fens2 Posts: 78

    so your connection does not drop when the device is in standby, and after this wifi is disabled and no VPN is active...?

This discussion has been closed.

📢F-Secure Quiz Challenge📢

Join our online quiz session on June 15th, 2023, at 11:00 AM EEST and stand a chance to win prizes.

Product & Pricing Info