F-Secure Freedome not connecting

F-Secure Freedome worked fine with my Widnows computer for a few days but now when I try to connect it, it does not work. For a while, it will say connecting after which it says that it is turned off. This has been going on since yesterday. I tried changing my location, restarting my computer and reconnecting to the wifi but nothing worked. I don't want to try and reinstall it incase I lose my subscription.

What should I do?

Best Answer

  • ChameniChameni Posts: 235
    Accepted Answer

    Hi @tballege ,

     

    I'm able to connect to the Belgium server today, looks like it is working now. Could you please try it and revert back if the issue persist.

     

    Thank you.

Comments

  • Having same problem on 1 win10 pc and 2 Android devices

    with Brussels location since yesterday

  • Is working on Amsterdam location
  • LakshLaksh Posts: 4,430 Community Manager

    Hi @hbruce,

    May I know what is your OS? How many devices are currently having Freedome?

     

    Hi @tballege,

    Due to some technical reasons, the Belgian location is down for the timebeing. We will update you once it is up again.

  • I'm using Windows. I have Freedome only on my laptop.

  • LakshLaksh Posts: 4,430 Community Manager

    Hi hbruce,

     

    I would recommend to uninstall and reinstall Freedome on your computer to see if the connection works after the reinstallation. We have the license transfer functionality with Freedome as mentioned in this article.

  • Belgium server works
This discussion has been closed.