Freedome window not visible after update

After a recent Freedome update I find that the Freedome window is no longer displayed, I just see a small white rectangle on screen.  The system tray shows Freedome is present and ON and I can select other locations successfully but the main dialog fails to display. 

This is on Windows 7.  I've tried restarting the laptop, and also shutting down Freedome using the system tray icon menu and then restarting Freedome from the desktop icon.  The results are always the same: system tray icon appears and message saying I'm protected but no main dialog window when I click on the taskbar icon, or  when I select Help or About from the system tray icon menu.

When it starts up I also see a brief pop up from the system tray announcing a Happy Anniversary offer.


  • EliasHEliasH Posts: 3

    I have the same problem!

  • ChameniChameni Posts: 235

    Hi EliasH,


    Welcome to our Community.


    May I know in which OS you installed Freedome on? And which version of Freedome is installed currently?

    Is there any error message seen when you try to open it?


    Thank you



  • ChameniChameni Posts: 235


    Hi Stomper,


    Sorry to hear about your trouble! This is a known issue and that our team is working on a fix for it, we will update you once there is any feedback about this issue.



  • EliasHEliasH Posts: 3

    Windows 7


    And ther's no error message. Only that white box when I try to get the Freedome window visible.


    And that's why I can't type my code to get the Freedome to work so I have it just installed but not working.

  • ChameniChameni Posts: 235


    Hi EliasH,


    Thank you for the update, this is a known issue and that our team is working on a fix for it. We will keep you posted once there is any update on this.


    Thank you

  • ChameniChameni Posts: 235

    Hi @EliasH and @stomper ,


    We have a workaround for this Freedome issue, I will send Private Message to both of you with the steps to be tried.


    Please revert back to me in private message if you need further assistance.


    Thank you and have a nice day.

  • martinkmartink Posts: 402 Adventurer

    Please clarity: Is it the Freedom Icon in system tray you are talking about or the real Freedome program window?

    I have not seen the icon for a while and cannot tell if Freedome is on or not (the setting is not to start Freedome when Windows starts) but the Freedome service is started automatically.

  • EliasHEliasH Posts: 3

    It is the real Freedome program window.

  • martinkmartink Posts: 402 Adventurer

    Thanks, I do not have a problem with that, just the icon does not display in the system tray.

  • VeijopVeijop Posts: 1
    Do you have workaround for this Freedome issue? I just found same situation from my friends windows 7 laptop. Icon works, but program itself open as small white box.

    Installation exe was latest.
    Laptop Samsung R730.

    Costs two coffees and one rustica bread.
  • martinkmartink Posts: 402 Adventurer

    My problem the icon not displaying in the system tray is solved.


    Once I got Freedome Protection turned on the icon is visible in the system tray. It is in the bottom row so when the mouse is hovering over it the text in the popup buble is not visible.



  • Can you give me also some advise for this problem? Private or public, doesn't matter.

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Luolamies, 


    I noticed that you opened a support ticket, and I highlighted it to our support so that someone can get back to you.

This discussion has been closed.