365 day subscription (paid for) has expired after 6 months

I PAID for a 5 device licence for 1 year. And it has just expired after 6 months! This was not a trial subscription but a paid for licence.

 

Freedome regularly asks me for 'Elevation'. When I agree to this, I  have to resubmit the Code. This has happened about 8 times I think over 6 months.

 

Now it says I have used all my installations. And to repurchase.

 

I have only used Freedome on 1 machine, and have a licence for 5 machines,  for 1 year.

 

Please help as I am reliant on VPN at the moment.

 

Steve

Account Reference Number: xxxxxxx

Product: F-Secure Freedome, 12 months for 5 devices

Macbook Pro 2014, OSX 10.9

 

EDIT: removed PII

 

Comments

  • <p>I PAID for a 5 machine licence for 1 year. And it has just expired after 6 months!!??

    </p><p>&nbsp;<br></p><p>

    Freedome regularly asks me for 'Elevation'. When I do i have to resubmit the Code. This is very annoying.</p><p>

    Now it says I have used all my installations. And to repurchase.

    </p><p>

    I have installed and activated on 1 machine, and have a licence for 5,  for 1 year.

     

  • Mine is the same error message as Whitefox:

     

    Screenshot of the error message :

    "Error-You have reached the maximum number of installations with this code.Please make a new purchase to extend your Freedome subscription."

     

     

  • Hi,

     

    Please advise if I am posting messages incorrectly. I have been reading other posts where people are getting replies to their issue, which is either the same, or similar.

     

    There seems to be many people having very similar problems.

     

     

    I purchased via F-Secure website

     

    Thanks,

     

    Steve

  • Laksh
    Laksh Posts: 4,444 Community Manager

    Hi Steve,

     

    Welcome to our Community! Currently, there is no option to reset the code in Freedome. Our RND is working further on this functionality.

     

    As I checked with our support team further, I see you have contacted us for your issue. Hope your issue has been addressed by our Support team. Please do let us know if you are still facing any problems with the code.

This discussion has been closed.