Goodbye F-Secure Freedome VPN

TheStupidOne Posts: 2 New Member

Goodbye F-Secure Freedome VPN


I have to say that one of the worst decisions I have ever made regarding software for my Laptop is taking out a 12 month 5 user subscription with F-Secure Freedome Software in mid August 2015.

Whilst not a PC novice nor am I an expert, but for the most part I can generally find my way around most problems that crop up, that may or may not be with the help of the software vendor's support team. There again I may just be fortunate as all of the software I have installed on my Laptop has, for the most part, installed and worked without any problems, as I expected. The few problems that I have encountered I have managed to correct, sometimes with the odd email or phone call to their help line / support team.


However since installing F-Secure Freedome four months ago I still have not been able to use it. I have encountered several different error messages which I still cannot find out how to correct. These are shown below.


 23-09-2015 09-38-00.png


23-09-2015 17-45-39.png




23-09-2015 18-23-33.png


23-09-2015 21-16-56.png


23-09-2015 21-17-12.png


24-09-2015 09-04-28.png


24-09-2015 09-04-43.png


24-09-2015 09-33-12.png



I have also spent hours trawling through the so called Knowledge Base trying to find the information I need to rectify the problems I have encountered with F-Secure's Freedom Software, which according to F-Secure's website and sales blurb features "Elegant Simplicity", something I have found it to be anything but. In fact looking back over the past 25 years of using a PC from DOS 5 and Windows 3,  and all the different software vendors and service providers I have used, I have never come across one that seems to rely solely upon its own customer base to sort out any problems that other customers have using software which they probably have little or no understanding of themselves, a case of the blind leading the blind!


I was going to ask for a refund and uninstalled Freedome and then forgot about it until I received an email about Black Friday discounts and thought I would give Freedome another go and started to re-install it, however it wouldn't install even though the install process started and it went through the preliminary progression to where the spinning time ring was whizzing around, and around and around, and around and around, and around and around, well you get the picture, and around and around, and around and around, so I closed the program and started again this time after several minutes of nothing, an error message appeared saying error code 7 and nothing else. I went to the knowledge base and looked up error code 7 and guess what, everything with the word "code" came up, and everything with the number "7" came up, but sadly never together with an explanation of the error code 7.


To add further to this crazy system, another thing I came across during this four month period of little to none use of Freedome VPN, is that if you have to re-install your software for any reason after having installed all of your legitimate licences on the equipment for which they were purchased, you then have to post some request on this system, which I assume some overworked and overstretched support worker eventually reads at some point in time, before you can rectify the situation and get back to using the software for which you paid hard earned cash. I have no idea how long this process takes, I doubt if it's minutes,  it may be within the first hour, or it may be hours, or it could take days, so guess what, F-Secure can stuff their Freedome where the sun don't shine, I'm off to find something better, which is certainly more user friendly and with proper support should I need it, and not a system which seems to rely heavily on other customers resolving similar problems, and a system which relies upon a totally inadequate collection of badly organised and superfluous data. As far as a refund goes I doubt if F-Secure will read this before next August when my licences run out, and besides, they seem as if they could do with it to help with starting their none existent support team!


  • martink
    martink Posts: 423 Influencer

    Installed Freedome trial yesterday on my W10 pad. Today in UK using Vodaphone mobile connection in my phone and the phone as a WiFi hotspot. Canät connect to any site when Freedome is on.

  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi @TheStupidOne,

    I went through your post and I did some check on the Error 7 with the Freedome installation. We do have a few reports of this error with the installation. I am sorry to hear that you you having other issues with the Freedome product as described in your post.

    Regarding your error 7, we have released a new version update just released yesterday which should address this issue. Please try to update the application by opening Freedome as there should be a popup to update to the new version. Kindly do try to update the Freedome product and let us know if it worked.

    However, if your issue persists even after the update to the new version or if your other issues persists, I would recommend to open a support ticket or chat with our support team in order to troubleshoot further. You can also share the support ticket opened with me via private message so that I can followup with the support team. The license reset is currently not possible with the Freedome code; but our RND team is working on that.

    Based on your post, I do see you would like to go for a refund. If you would still like to proceed with the refund, please do confirm with me so I will check further on this.
    Once again, our apologies for the frustration you've been experiencing. Please do let me know of your update.

  • martink
    martink Posts: 423 Influencer

    For me that chat sounds best when I aam back in Finlandia.

  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi @martink,


    Since you mentioned you are using your phone as a hotspot, tethering is not currently supported with Freedome. You check this article here.

  • martink
    martink Posts: 423 Influencer

    Thanks will check with my home WiFi then.

    Does it support Mokkula or Huawei  E5776

  • martink
    martink Posts: 423 Influencer


    No. Android doesn't support creating a portable Wi-Fi hotspot when the VPN connection is on. Consequently, when Freedome is switched on, you can't share your Android device's data connection with other mobile phones using Wi-Fi hotspot.

    sounds like Freedome is installed on the phone.

    In my case it is not installed on the phone which is the WiFi hotspot but on a device using the WiFi..

  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi martink,


    If Freedome is not installed on the phone which has the WiFi hotspot enabled; and if it is on the device which is using the WiFi, I would recommend to check if this happens only on this network connection. Or you may try to connect to other WiFi networks and see if Freedome connections works. Try to browse through different websites and do let us know if the issue persists.


    Is there any particular error messages seen when connecting to the websites?

  • martink
    martink Posts: 423 Influencer

    Freedome version Teclast pad W10 1.0.2352.0 (the trial updated this morning)

    works OK with my home WiFi. Does not work with my phone as hotspot.  It only says Web site i not available on the half a dozen sites I tried.


    Freedome version MSI GP W81 1.0.2246.0 (after re-checking this is the licensed product not yet updated) works just fine using the phone as the hotspot on those same half a dozen sites (doemstic and foreign)


  • martink
    martink Posts: 423 Influencer

    Another test

    Freedome BETA VERSION 2.0.2352.0 on T4300 laptop Win10 64 bit 
    No problem accessing web pages when using the same Android phone as WiFi hotspot.

  • KAC
    KAC Posts: 1 New Member

    No problem at all, use it for six months.


    But, I use Google DNS on my regular Wifi:  


    Maybe that has something to do with your problem? I your Internet Provider has som strange stuff going on you maybe loose your DNS??



This discussion has been closed.
Product & Pricing Info