Freedome on windows 8.1 not working

Hi,

 

Freedome worked fine couple of weeks and now it works quite strangely. Internet connection doesn't work at all if protection is on and traffic protected increases 0,1 GB in every couple of seconds.

 

At the moment it says approx 500GB.

 

What can I do to fix this?

 

Br, Jyri

 

Comments

  • JAP
    JAP Posts: 4

    Can I try to re-install it? can I use the same subscription key without any problems?

  • Tehfcae
    Tehfcae Posts: 107

    Before you try resinstalling it check the following:

     

    You have enabled ipv6, to check:

    1. Open up network and sharing centing through the control panel.

    2. Select change adapter settings.

    3. Select properties after right clicking the freedomVPNconnection.

    4. Make sure Internet Protocal Versionc (TCP/IPV6) is checked.

     

    Are you able to ping websites when connected to Freedome?

    to test:

    1. Open command prompt

    2. Type: ping google.com

     

    Also please run a speed test from here: http://www.speedtest.net/ and let us know the results.

  • JAP
    JAP Posts: 4

    IPV6 is checked.

     

    ping google.com says:

    "Ping request could not find host google.com. Please check the name and try again."

     

    And speedtest cannot be run with freedom. Without Freedome speedtest gives 6.81 / 0.85 (connection 8/1).

  • Tehfcae
    Tehfcae Posts: 107

    It may be that Freedome is timing out due to a slow internet connection. Do you have access to a network with speeds above 7 down, 1 up? If so does Freedome work on that device at that location?

     

    Also what type of device is it? (tablet, laptop, desktop...)

     

    You may also be on a trottled network, is this a home, corpate, school, government, or public network?

  • JAP
    JAP Posts: 4

    10+ down, 3+ up and same results. Network connection stops working and traffic protected increases quite fast.

     

    It's 10 inch laptop/tablet combination in home network.

     

    Freedome works fine in android devices.

This discussion has been closed.