F-Secure Host Process Error


a message from windows keeps popping out every 30 seconds or so telling me there's been a problem with F-Secure Host Process (it's the classic windows message that tells a process will be shut down and asks if you want to send informations about it).

By checking task manager I've found out there's about 10 processes running all named "fshoster32.exe". I think the two things might be connected. 

I haven't also been able to scan my system with F-Secure since this problem came up. 

Thanks in advance for any answer.

Accepted Answer


  • JaniashviliJaniashvili Posts: 469
    It should have few fshoster32.exes, but I don't think that much. Had you tried to restart your computer? It does still so?

    (you can try to "request support"(in support page) as such bugs aren't quite often seenand give them fsdiag.zip (find "support tool" or "fsdiag tool" or similarly called application in the start menu's F-Secure folder and launch it))

  • arvoarvo Posts: 2



    I'm having same problem too. OS is Windows XP. Reinstalling F-secure didn't help anything. I'll try to send fsdiag tomorrow

  • Jari-PJari-P Posts: 79 F-Secure Product Expert

    Hello arvo,


    Please contact to our technical support regarding this problem.



  • etomcatetomcat Posts: 1,319 Superuser



    This morning, I got two phone reports about this error message from our home users.


    One says he couldn't even access the net until FSIS was disabled! If that is the case, not even the superb AUA-based update and patching technology may be able to remedy the issue automagically. That's worrying!


    Sincerely: Tamas Feher, Hungary.

  • etomcatetomcat Posts: 1,319 Superuser

    Dear Jari,


    Just got an FSDIAG file from an affected customer and forwarded it to the FSC Partner Support e-mail, with the subject "F-Secure Host Process has crashed and stopped with FSdiag (Top URGENT!)". I haven't got an auto-response with the SR ID case ticket code yet.


    Sincerely: Tamas Feher, 2F 2000, Hungary.


  • etomcatetomcat Posts: 1,319 Superuser



    I am unable to submit the concerning FSDIAG, I get Message Processing Timeout errors!


    Sincerely: Tamas Feher, Hungary.

  • etomcatetomcat Posts: 1,319 Superuser

    Dear Jari,


    Please check the "SR ID 1-561432685" case. I submitted the correspondingly numbered FSDIAG files via F-Secure's FTP server, because there a problem with F-Secure HQ's Proofpoint gateway when hhandling large e-mail attachments.


    I think this software bug needs urgent fix.


    Sincerely: Tamas Feher, 2F 2000, Hungary.

  • Jari-PJari-P Posts: 79 F-Secure Product Expert

    Hello Tamas,


    Thanks! Found your support request and we are already investigating this with high priority. We will get back to you as soon as we have the fix.



  • MadDocMadDoc Posts: 2

    My girlfriend has the same problem. Looking forward to a fast solution. It's VERY annoying.

  • MikkeFinMikkeFin Posts: 2

    I have this same problem too.

  • I have exactly same problem too, and I'm worried about it.

    It makes me think if my desktop computer is still secured against viruses and spy software ?

    I did run Microsoft's msert software to check if my computer is infected by the virus but it wasn't.

    I'm glad that I'm not only one with this.


    I hope that I get soon a solution and an explanation for this Error message.   

  • MikkeFinMikkeFin Posts: 2

    Thank you arvo. I think that solved my problem too.


  • MadDocMadDoc Posts: 2

    Yesss! My girlfriends computer works with this fix also.


    This solved my Error Message problems too  Smiley Happy 

  • hhhhhhhhhh Posts: 1

    And it started again.

  • nikkinikki Posts: 1



    Is there any official solution to this problem? It is quite annoying.

  • ZodZod Posts: 2

    Having same problem since upgrade. I am having considerable hard drive access it takes approx 30 minute for PC to stabilise. The FSSm32.exe is forcing massive amounts of read writes to the disk.  In viewing the tasks its shows that the fsecure gateway has continually failed to initialise.  On shutdown there is always a fshoster message showing that the task has not completed shutdown.

    Additionally when fsecure startsup there is no antivirus protection and a windows message states this. It is not until about five minutes into boot time that the fsecure icon appears in the bottom right corner.


    All of this leads me to believe that fsecure is not functioning correctly since an update. Its now getting to the point where I will have to remove and get another proection method as  this looks like it has been compromised in some way. I have sent fsdiag to F secure. But I think this may be something fundamental with the new build or its install.


    Running XP SP3.

  • JaysonJayson Posts: 595


    Please note that the fix was released through automatic update channel as F-Secure Scanner Manager Update 2013-04-26_01.


    Best Regards,

  • ZodZod Posts: 2

    Jayson, not sure the fix is working. My machine was particularly worse last night. Today is the 2nd of May so we are now nearly a week past the fix being updated.  I will of course check that the fix has been installed, but last time I looked it seemed that the patches were also not being installed or at least that was what the fsecure log was telling me.


    I have internet connection and can download emails, so its not a network problem.  The fact that the fshoster.dll is not shutting down at PC shutdown tells me that something is not quite right with the software. Any ideas on what I should be checking? The PC is almost unusable in its current state.  The fact that FSSM is maxing out the hard drive read/writes does not seem right either. Is it always going into a scan at startup.  I have three licences and the other two machines are fine its just this one with all my work on, so I am going to have to do something drastic shortly.


    But to be candid , I have thought that the new fsecure product is not  as good as it used to be and I am a long term customer of the software. It now seems to be very buggy and slow since 2011. Hopefully you will be able to restore my confidence.

  • chonchchonch Posts: 10 F-Secure Product Expert

    Hello ,


    Please kindly download the fix from:


    ftp://avhfshosterSmiley Tongue%[email protected]/AVH_replacer.zip


    To install the fix, you may need to do the following:


    1. Extract the zip file
    2. Run install_cmd


    The fix was released to the channel but unfortunately the problematic component is related to our automatic update functionality. Thus, the fix may not be taken into use.


    In case issue remain after installing the fix, please kindly open a support ticket for further assistance required:




    We apologize for the inconvenience caused


    Thank you

  • Hiya All,

    Had the same sort of problem, The AVH_replacer worked in MOST cases.

    On the machines it didn't fix, I had to do a "new" install AFTER running the uninstaller.


    BTW, after this (type of error) you have to do a diskcheck, because the registry can't close properly.

    I even had HARD errors (plural). 


    Have a good one. 

This discussion has been closed.