Freedom not working in Egypt

ahm3d
ahm3d Posts: 5 New Member

Could you confirm that Freedom is not working anymore inside Egypt? I tried a lot with almost all the servers (Milan, Espoo, Prague, ... etc) but it seem like Freedom couldn't make a connection. Maybe the Egyptian government blocked Freedom's servers.

Comments

  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi ahm3d,

     

    Just to get more information on this: Do you see the connection issue with all the devices?

    Have you tried a different network to see if the issue persists?

     

  • ahm3d
    ahm3d Posts: 5 New Member

    Yes, I tried.. the problem is still exist. Freedom cannot connect to the server.

    Stina52
  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi ahm3d,

     

    Egyptian government blocks actively VPN products; they also have a long history with blocking access to, for example news sites not approved by the government. Unfortunately, our possibilities to affect this are limited.

    Stina52
  • Stina52
    Stina52 Posts: 2 New Member

    Same problem, I just downloaded the service but can not use it Smiley Sad Too bad ....  

  • Näsäviisas
    Näsäviisas Posts: 784 Superuser
    @Stina52

    Are you Stina in Egypt too?
    Or some where else?
    In what country?

    Asking
    Näsäviisas
  • Stina52
    Stina52 Posts: 2 New Member
    Yes that is why I comment on this
  • Näsäviisas
    Näsäviisas Posts: 784 Superuser
    @Stina52

    I'm really sorry.
    Are going to stay there for a long time?
    Or is it only temporary?
    I don't know anything about Egypt.
    How careful has to be out there?
    I hope, that you find other ways to sure your privacy ja security.

    Good luck!
    Näsäviisas
  • ahm3d
    ahm3d Posts: 5 New Member

    @Näsäviisas & @Laksh

    I think the problem in Egypt is that the DPI (i.e. Deep packet inspection) drops the packets during the handshake so Freedome cannot establish the connection successfully.. so, my question is: 

    Is there any way to obfuscate the connection during the handshake? (i.e. Handshake Obfuscation)

    It seems to me that Freedome doesn't have much custom settings (e.g. to configure it to connect through another VPN to bypass the DPI).

    Stina52
This discussion has been closed.
Product & Pricing Info