Error 500

Hey! I just got myself Freedome 30 days free subscription and everything goes fine until Freedome asks me to name my computer. After I name computer and press accept/apply it goes to error 500 screen. What is the problem and how do I fix it?

Best Answer

  • LakshLaksh Posts: 4,432 Community Manager
    Accepted Answer

    Hello Everyone,

     

    There was a server-side issue when adding devices with Freedome for the F-Secure TOTAL customers. The issue has been fixed now and devices can be added as usual.

    Ukko

Comments

  • UkkoUkko Posts: 2,999 Superuser

    Hello,

     

    Good to contact F-Secure Support Channels (chat/phone):

    https://www.f-secure.com/en/web/home_global/contact-support

     

    Previously there was some words about such trouble (under community); More sounds as internal trouble for F-Secure's servers or incompatible with certain device/system;

     

    Does your experience about mobile device or desktop, which OS? Maybe it can be useful to know.

     

    Thanks!

  • Hello, I use Win 10 OS and it seems to be somekind of server problem to me. I try to contact support tomorrow if the problem is still persistent.

    Ukko
  • UkkoUkko Posts: 2,999 Superuser

    Also...

     

    Does there Freedome subscription provided by some companies (like ISP or so)?

    I mean -> you choose "login" as certain service provider under Freedome UI? Or this is direct F-Secure Freedome (Total?!) usage?

     

    Also possible to re-check next topic (with related meanings):

    https://community.f-secure.com/t5/F-Secure/Can-t-sign-in-to-freedome/m-p/97546

     

    Thanks.


    I randomly "marked/accepted" your reply as solution for your topic; This is wrongly, of course (because required official response or proper result) and topic is not sorted yet.

    Sorry for this! And I think that F-Secure Community Managers able to re-fix this later (or tomorrow); Or maybe you're able to "unchoose" reply as "Solution";

     

    Thanks!

    Jakkis
  • I use F-Secure Total and downloaded both of the programs for test. I created F-Secure account and logged in with those, everything goes fine (I get logged in) but when it asks to name my computer it shows me error 500 code. I have tried it multiple times but it is just same results all the time.

  • The same here. Test subscription, Windows 10, installation goes fine until I'm asked to "Name new device", and then I get Error 500. Tried reinstalling several times, to no avail.

    UkkoJakkis
  • UkkoUkko Posts: 2,999 Superuser

    @Tom_R wrote:

    The same here. Test subscription, Windows 10, installation goes fine until I'm asked to "Name new device", and then I get Error 500. Tried reinstalling several times, to no avail.


    I able to add -> that I also tried and possible to repeat such trouble under my one of Windows 10 systems;

    I tried next steps:

     

    --> Uninstalled Freedome under system (most likely system was with Freedome previously);

    --> Registrered trial account for F-Secure Total (but did not activate mail-address); And downloaded F-Secure Freedome Installer from My F-Secure Account portal;

     

    --> After installation Freedome "welcome" with pop-up for activate/login subscription; Add credentials for account; Choose name for device and got "Internal Server trouble"

  • UkkoUkko Posts: 2,999 Superuser

    @Laksh wrote:

    Hello Everyone,

     

    There was a server-side issue when adding devices with Freedome for the F-Secure TOTAL customers. The issue has been fixed now and devices can be added as usual.


    Just as my own feedback: on current day -> indeed.. situation is fixed with my check-device/system; I added device-name and Freedome did activation for trial-time; 

  • Works now, thanks!

This discussion has been closed.