Unable To Install FreedomE VPN app?

Hi,

 

Sorry to be creating a thread about this, but I've been trying to solve this problem without anything resembling progress...

 

This is what happens:

I open the FreedomE VPN installer file "Freedome.exe" that I downloaded from the f-secure.com website and a window opens, but it's just a black screen with no readable text or anything else. I've had it running for the past 20minutes and it's still just a black screen.

 

I've tried restarting my PC and also doing a shut down where I turn off my PC completely and the same thing still happens.

 

I'm running Windows 10 with the most recent updates installed.

 

My PC works fine and here are the specs:

 

CPU is an Intel quad core and I've got plenty of RAM available.

 

No other apps running in the background.

 

Thank you!

antonka

Best Answer

Comments

  • UkkoUkko Posts: 3,140 Superuser

    Hello,

     

    I will suggest to directly contact F-Secure Support Channels (chat/phone):

    https://www.f-secure.com/en/web/home_global/contact-support

    (or your local F-Secure website - where can be another chat-work-hours);

     

    Since they able to troubleshoot it much more speedy.


    But as some of my suggestions:

     

    --> Did you try launch "Freedome.exe" as Administrator (by rightclick context-menu)?

    --> It should not be a reason - but maybe you able to re-check and install latest available drivers/updates for your videocard? Freedome probably used "OpenGL" (support required);

    --> Maybe you able to manually re-check some logs under system directories OR with Windows Journal Events - if there have some related notifications, strings or mistakes at this timestamp?

    --> Does there installed any security software (not by F-Secure) - which able to prevent proper launch?

    --> Does it work before this current try?

     

    Thanks!

  • Hopeful_FutureHopeful_Future Posts: 53 Observer

    Ukko, your reply is much appreciated!

     

    I was able to use FreedomE before the most recent update.

     

    When I tried to update FreedomE VPN from within the FreedomE app the same black screen that appears now was displayed.

     

    My graphics card driver was updated in around April 2017 so it's still recent.

     

     

     

    I don't have any other 3rd party security software installed.

  • UkkoUkko Posts: 3,140 Superuser

    Hello,

     

    Sounds like if there changes with F-Secure Freedome graphic (based on OpenGL? Qt5? points);

     

    If we ignore points with broken 'installation/reinstallation/update' based on previous installation;

    So - I able to think that there required (as one of common and brief steps) investigation - which can be as:

    --> manual try to re-check some logs under system about Freedome or Windows Journal Events (with other mistake-strings);

    --> contact Support with Fsdiag ( https://community.f-secure.com/t5/F-Secure/How-can-I-generate-a-Freedome/ta-p/77454 );

     

    if another suggestions (like administrators-rights run) and your tries (as there all updates for system is installed; drivers with latest available) not useful with current stuck.

    Also maybe there will be replies from another users - who also experienced about this situation (?!);


    Thanks!

  • Hopeful_FutureHopeful_Future Posts: 53 Observer
    Ukko, your ideas are greatly appreicated!

    Are you saying I should update my Nvidia graphics driver?

    I'm running a Nvidia GTX460 graphics card.

    What's the difference between opening the installer "freedome.exe" normally and opening it as an Administrator?
    Ukko
  • Hopeful_FutureHopeful_Future Posts: 53 Observer

    Your reply is much appreciated!

     

    I just upgraded my graphics card driver to the most recent version from Nvidia.

     

    Then I tried opening an old installer of "Freedome.exe" and I'm able to see its contents clearly!

     

    However, I've been trying to download the most recent version of the "Freedome.exe" installer from

    https://www.f-securestore.com.au/ but it seems that the website is offline.

    Ukko
  • UkkoUkko Posts: 3,140 Superuser

    Hello,

     

    Good that maybe it was useful and helpful (possible that "old_installer" was too old and just with recent installers can be trouble; but yes - after your topic - there was recently else one update).

     

    What about latest Freedome URL -> not sure about provided URL - but you able to use F-Secure home_global official website (Freedome part):

    https://www.f-secure.com/en/web/home_global/freedome

     

    Where will be direct URL for latest available build with this URL;



    Also you able to switch (or try to do so) "home_global" to "home_local" (it possible under right-bottom part of page - where available to choose certain "lang"-setting);

    Not all of "local" websites with 'updated' view. And also F-Secure probably switch to design about "f-secure.com" as main domain (where you able to choose certain supported location or to use "home_global") - while previously there was possible to use 'certain local website' (maybe it valid for your experience); Or maybe (if it was only local official design for their online store/shop) -> F-Secure forget to "renew" account under shopify-service?!

     

    Thanks!

  • Hopeful_FutureHopeful_Future Posts: 53 Observer

    Ukko, 

     

    I appreciate your advice! 

     

    I tried going to your link, but it seems different to the domain for F-Secure's community, which is "community.f-secure.com/?

     

    Google Chrome is telling me they're different...? 

  • UkkoUkko Posts: 3,140 Superuser

    @Hopeful_Future wrote:

    Ukko, 

     

    I appreciate your advice! 

     

    I tried going to your link, but it seems different to the domain for F-Secure's community, which is "community.f-secure.com/?

     

    Google Chrome is telling me they're different...? 


    Hello,

     

    So.. there probably can be long answer, but I will try just to think about certain points:

     

    --> If we talk about next URLs:

     

    "community.f-secure.com/"

    "f-secure.com/" (generally -> "www.f-secure.com/")

     

    This is "different" websites (and both 'subdomains of something'), but there next meanings:

    - f-secure.com is main domain for F-Secure website (official registered domain-name for DNS-handling);

    - community.f-secure.com is subdomain for f-secure.com;

     

    "f-secure.com" can be with different subdomains; They able to be with different IPs, purpose and so. Since they can be hosted on different technologies/services/servers and so;

    This pages usually work under HTTPS (with using TLS and certain certificate); Certificate can be for domain/subdomain or so;

     

     So - I not sure what "Google Chrome" means about "difference" - but there can be different "certificates" for community page and for main F-Secure domain;



    SITUATION:

     

    You able to open official main F-Secure website by this URL:

     

    https://www.f-secure.com

     

    (or you able to open it directly from community page -> left-top corner of community -> where "F-Secure logo" before 'community'-word will open main F-Secure official website);

     

    With default setting it will redirect you to your local website (for example, based on system's language - if you allow such ability); Or will open "general" webpage;

    For example, for UK-website it will be redirect to next URL:

     

    https://www.f-secure.com/en_GB/welcome

     

    This is "welcome"-page under main F-Secure domain for UK-users;

     

    Under this page you able to switch to page about Home Users solutions by using (right-top menu as "For Home"-button); It will open next URL:

     

    https://www.f-secure.com/en_GB/web/home_gb/home

     

    This is "main page for Home Users solutions"-page under main F-Secure domain for UK-users;

     

    Under this page you able to switch to (by different steps) F-Secure Freedome page (as example -> Menu  -- Products-dropdown -- F-Secure FREEDOME VPN); It will open next URL:

     

    https://www.f-secure.com/en_GB/web/home_gb/freedome

     

    This is "Freedome-page" under main F-Secure domain for UK-users;

     

    Under this page you able to use button "Download for PC" (Windows); It will open next direct URL for downloading latest available Freedome-build:

     

    https://download.sp.f-secure.com/freedome/installer/Freedome.exe

     

    Where some-levels subdomains (download.sp.) under main domain f-secure.com (and certain path to certain resource - there it will be "Freedome.exe" - which you able to download; With previous situations it was certain resource as ".html"-page (for example) - which also downloaded - but browser able to show it under "browser");

     

    Also there available "Downloads"-page for Home Users solutions:

    https://www.f-secure.com/en_GB/web/home_gb/downloads

     

    So -> Does there any notification from Google Chrome about F-Secure.com website? Or about direct URL for download file?

     

    With your experience -> if https://www.f-secure.com do not redirect to your local website (or under any of "UK-example" pages) --> you able to switch lang-settings under "bottom-right" or "bottom-left" corner);

     

    And it should be valid - if there missing any changes/configuration under system or router (when DNS/IP pairs did not valid);

     

    Sorry for my long reply.

     

    Thanks!

This discussion has been closed.