Banking Protection on false site


I use F-Secure SAFE 17.0 on my Windows 10 PRO-64 system. If i surf via EDGE to ""  the banking protection activate! But the site isn't a Online-banking Homepage! What can i do, that the protection don't activate automatical on this site?

Thank You,



  • Ukko
    Ukko Posts: 3,611 Superuser



    Sorry for my reply. Previous reply was with most helpful solution;

    But just some suggestions:


    --> Because there http - Banking Protection activated by something else than;


    If I normally understand trigger can be (at least) their "subdomain/cdn" as (https);

    for example, next direct URL (picture-resource from

    Will trigger Banking Protection flyer with Internet Explorer 11 too;


    So, most likely F-Secure Labs should verify it (as their own proper view)... but you anyway able to transfer directly this url as "" (or "" - but it not enough maybe) and since there redirect to main page (you able noted example with picture);


    --> As workaround (if you do not use alternative browsers) there possible to use default system Internet Explorer 11 (with Windows 10); 

    Where will be installed/enabled F-Secure Browsing Protection extension;

    It also designed for proper detection "banking session pages" (as I can to think);

    At least, with my experience Internet Explorer 11 did not trigger BP-flyer when I open (or your URL), but Microsoft Edge do this from first (with main page); If I will disable extension under Internet Explorer 11 -> opening will trigger BP-flyer;

    Such situation with your experience - becase F-Secure did not provide extension/addon for proper HTTPS support (and some other points) to Microsoft Edge (yet);


    Sorry for my reply.



  • Skateatround
    Skateatround Posts: 2 New Member

    Thank you very much for the link!

This discussion has been closed.
Pricing & Product Info