latest update install problem

opticalia Posts: 8 Explorer

I got windows 10 pro, latest update wont start to install even if i start that on administrator mode, anyone else have this or is something wrong in my computer?


  • Näsäviisas
    Näsäviisas Posts: 784 Superuser

    More information please about the problem. What is connection to Freedom? Or other F-S app?

    Or is it the matter of Windows10 pro?

    " latest update wont start to install"


    with greetings


  • opticalia
    opticalia Posts: 8 Explorer

    just everytime i start computer and freedome starts with it, it says that new version is available, and choocing yes opens web page that starts to download freedome.exe, but i cant open that file, nothing happens.


    I have updated it before and then it worked no problem


    Im using old version no problem. Maybe windows 10 somehow blocks me running it 



  • Näsäviisas
    Näsäviisas Posts: 784 Superuser

    I found out, that there has been problems with Win10.  You are not the only one. 

    Have you seen error information on the computers screen? When updating the new version.




  • opticalia
    opticalia Posts: 8 Explorer

    no messages, just nothing happens, have been trying to run file with freedome closed too, and killing process and then running it too, also tried compatibility modes as well as run as administrator ofcourse, im thinking windows has been getting lots of heavy updates lately so maybe theres the reason, i can still try to re install software that will most likely help.

  • opticalia
    opticalia Posts: 8 Explorer

    eek, after uninstalling it i cant install it back since install screen not opening, something wrong with this win10 need to look fixing it or reinstalling :/

  • Näsäviisas
    Näsäviisas Posts: 784 Superuser
    You will find FREEDOM documents:
    Click three red lines on the screen (F-S Community), then How-to & FAQs,
    select english and then home security, Freedom for Windows - advice.

    I hope this could help you!
    If not, take contact to support.
  • Ukko
    Ukko Posts: 3,611 Superuser



    Sorry for my ask and suggestions;


    But do you able to re-check small points?


    --> Does there work any other executable files under your system?

    Do you able to launch any of .exe-files?


    --> Do you able to re-check about Freedome installer (do you get it from official website?) by rightclick for freedome.exe (installer file), than choose 'Properties' and check if there can be 'blocking notification' under view (Windows usually able to give such 'byte' for downloads and some times it can be a reason for trouble with launch application); if it such situation - it should be visible for you (if you do not see anything wrong - so this is not trouble-situation or reason; if there can be such notification under properties-window - maybe you have to use unblock button);


    --> Does there possible that under system installed some other security software, which block running Freedome? Or what if there disabled UAC under your settings (?!)  - I not check it with Freedome (should require administrator rights probably for installing), but some software not possible to launch with such setting (even with administrators rights launch-option);


    Sorry for suggestions.



  • opticalia
    opticalia Posts: 8 Explorer

    tried that file directly from your link, same, 

    then i put UAC from second low setting to lowest possible, no luck, next i checkked windows event viewer if it has some info on crashing application there was some but not too much help:



    Faulting application name: FreedomeInstallerUI.exe, version: 1.15.3629.0, time stamp: 0x590af3e9
    Faulting module name: nvoglv32.DLL, version:, time stamp: 0x58f7f8c8
    Exception code: 0xc0000005


    Fault offset: 0x00acee5f
    Faulting process id: 0xd88
    Faulting application start time: 0x01d2d6e54fad9f70
    Faulting application path: C:\Users\OPTICA~1\AppData\Local\Temp\FS_FREEDOME_1\UI\FreedomeInstallerUI.exe
    Faulting module path: C:\WINDOWS\SYSTEM32\nvoglv32.DLL
    Report Id: f5521dd2-7940-4d5f-a296-9bb414d3ec03
    Faulting package full name:
    Faulting package-relative application ID:


    ** edit also other installers seems to work i tried a few like browsers and dropbox

  • Ukko
    Ukko Posts: 3,611 Superuser

    In somewhat reason there is Nvidia library (?); Just as suggestion:

    Do you able try to re-install NVIDIA drivers for your videocard (or install fresh driver for your NVIDIA videocard, if it indeed can be under your computer)?


    // later added: brief search for this .dll give results that it can be related (and as potential compatible trouble also?!) with OpenGL.

    Which maybe used by F-Secure Freedome.


    At least there also have next topic:


    and such article under Knowledgebase (generally HowTO/FAQs as Näsäviisas more properly called it)

  • opticalia
    opticalia Posts: 8 Explorer

    lately, also fifa 15 has stopped working months ago, but that can also be nvidia problem actually



    next im going to update nvidia drivers and if no help then re-install them

  • Ukko
    Ukko Posts: 3,611 Superuser

    Will be good if you back with feedback-result.


    During brief search with Google about this library-dll there also next 'recent' topic:


    Where says that (at least) something which can be related with 'such trouble' was based on 'latest' Nvidia drivers. Which maybe already not latest and current ones should be with 'fixed'-situation; If not (and try with updating/installing latest available for your NVIDIA Drivers do not fix situation) - you maybe able to re-check about certain drivers (as example, some of previous ones; for my videocard there available four builds for latest two months) ;




    My suggestion about UAC was mainly with meanings that if under your system it already with lowest-setting (as UAC disabled) - such setting can be a troublereason. And not like suggestion to try disabling UAC.

    / sorry for my worst English Smiley Sad /

    So, just do not forget back UAC to normal (Security and Safe) mode-level after your brief check steps (if you did not back proper protection level already, of course)! :)

  • opticalia
    opticalia Posts: 8 Explorer

    Ok, now im state of uninastalled all nvidia drivers and tried freedome installer, it works!


    thanks all, at least now i can try to test if it works when i install drivers back and so on

This discussion has been closed.
Product & Pricing Info