MacOS Sierra - Freedome suddenly shows "Fatal Error"

DennisB Posts: 2 Observer

I recetly upgraded to MacOS 10.12.4 (Sierra) and had Freedome installed before the upgrade.

After the upgrade to Sierra, Freedome seemed to work for a couple of days, but today when I start up my Mac I get a dialogue-box with the text:


"Fatal Error

Data required to run Freedome is missing or corrupted. Please reinstall the software"


I de-installed and re-installed the application but get the same error-message nonetheless.


I asked the application to save debug-logs by pressing the button marked "Send Error Report" and there was a .zip-file created, but it´s unclear to me to where I should mail this so F-secure support gets it?






  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi and welcome to our Community, DennisB!


    The error message is seen in Mac OS before and there is resolution by completely removing the program and reinstalling as mentioned in this thread. Have you tried to remove everything before the reinstallation as mentioned in the post?

This discussion has been closed.
Product & Pricing Info