Freedome subscription not working after computer restart

I have problem with my subscription for F-Secure Freedome product. I have paid for one year subscription for 5 devices. I have installed it on 2 phones and one laptop. For some reason the program on my laptop is telling me every day ( after shutting down the system ), that my subscription has ended and that I need to subscribe again. When I've tried to use the code , it told me, that I have already reached the maximum number of installations , let me release one, but it doesn't work anyway.
Only help is to reinstall the program again, and it  start to be quite annoying. But it still telling me, that I need to release some licence and let me chose one of three devices (I should have 5 licences) .
The product was bought through your official web-site. 

Trial version worked fine, without this problem.
My ref number is : xxxxxxxx


  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi vladimir1,


    Please let us know the following details to help further:

    1. Have you used the new Freedome license to validate the Freedome installation in your laptop? What is the current subscription validity date on your laptop?

    2. Was there any previous purchase of Freedome license which you were using on your devices?

    3. Are you using the recent version of Freedome installed? With the recent versions of Freedome, we have the license transfer option as mentioned here with which you can initiate the license transfer on your devices. Please check the link and try the license transfer.

  • Every time, after the computer is restarted, the Freedome tell me, that I need to log in ,because it is not activate. When I login the product tell me, that it is not active as there are no license available, so I need to release one of my 3 subscriptions (I should have 5 licences) .
    Devices showed on the list are :  one mobile phone, and two computers (The F-Secure Freedome is installed on 2 android phones and one computer - in which I have this problem) . When I release some devices and add this computer, it told me , that my subscription is expired.

    After reinstallation of the F-Secure Freedome, login and transfering one license, it works as it should, with correct subscription date  (until restart of course) . 


    On mobile phones  it works fine - my subscription is till 8.4.2018.

    Before I have used the trial version without adny problem.  The version I am using right now on the pc is 1.10.3502.0

  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi vladimir1,


    Based on your description, are you trying to take the Freedome license from Total? Do you have a Total purchase or are you using a Total trial account?


    If you have purchased Freedome multi device subscription, you can check the article here on how to take it into use.

  • I didn't realize, that there are more versions of the Freedome.

    I have installed the (just) Freedome one, and at the moment the problem with not working program after system reboot seems to be solved . 

    I will check if I got the right amount of licenses later.

  • So now it seems, that I have got wrong subscription code . I paid for 5 licenses , but I can't subscribe more than 2 devices. Any attempted to subscribe third device will end up with license transfering. However this will unsubscribe one of those two devices.

  • Hi Laksh,


    That's exactly what I am doing. As I wrote earlier, it solved my problem with forced reinstallation, but it occur , that I have problem with licences ,as my code doesn't allow me to subscribe more than 2 devices (and it should allow 5 )

  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi vladimir1,


    Kindly get in touch with our support team via chat/phone in order to troubleshoot your license issue further.




This discussion has been closed.
Product & Pricing Info