Cannot enable Browsing Protection extension in Chrome

Hi,

Just installed F-Secure SAFE on Mac OS X.

I cannot get the browsing protection extension for Chrome to work.

Chrome is running version 57.0.2987.110 (64-bit)

I install the extension from inside SAFE, and the extension in added to Chrome, but there is no way to enable it.

It seems to be the same problem described in this post:
https://community.f-secure.com/t5/F-Secure-SAFE/Browsing-protection-Chrome/m-p/83135#M14814

I have also tried removing the extension and installed the extension that is linked in the post, and that installs and enables the extension, but SAFE still complains that the extension is not enabled. And it does not seem to work?

Could you please advise on how to get this working?

F-Secure Safe is version 15629


Best Regards
Henrik


Answers

  • LakshLaksh Posts: 4,428

    Hi Phatn,

     

    I see you have already tried to install the extension from SAFE and also from the Chrome web store. Have you tried a restart and see if the settings are taken in place?

     

    What is the OS version of your Mac? If the issue persists even after the restart, I would recommend to get in touch with our support team via chat or phone so that they can look this further.

     

This discussion has been closed.