Subscription renewal fails and reinstall also fails with “No Internet connection”

Out of our two Windows machines the other got a new SAFE subscription renewal automatically (after a reboot), but the other one never did. Forcing a “Check for updates” reports success, but continues to list erroneously “Your subscription has expired”.


Trying to reinstall from a package downloaded from My F-Secure results in a false error message

“No Internet connection”. The same machine had a HTTPS connection to F-Secure and also to the AV update server from the SAFE installation. The Try again option did nothing, neither downloading another install package exe from MyFS.


This is quite frustrating. There were no problems with SAFE in this machine before the subscription expired and was renewed. There is also no problem with the other machine.


Is there a logging function that can be invoked from the installer to find out why it's falsely claiming no Internet connection?


  • After uninstalling the previous SAFE installation, we now get “Your current version of Windows is not supported”. The machine is running XP Pro SP3. Where can we download a version that installs on XP?


    The previous installation had no problem running on it, the problem only started with the inability to renew the fully paid subscription.

  • Further investigation revealed that there is a bug in the current network installer. It gives this “No Internet connection” error message even when the Internet connection is fine, but it is otherwise unable to download the actual install package from F-Secure's servers, presumably because they have been intentionally removed.


    When we had SAFE still installed and working until the subscription renewal failure, the new installer didn't give the “not supported OS” error. It presumably tried to download the install package of the 2016 version and just couldn't find it from the server. It should have given an error message about the server failing, not the Internet connection which was fine.


    When we tried to launch a 2016 version of the network installer of SAFE, which was used previously to install SAFE in this XP machine, it gave a different error message: “Could not download the required files. Check that your network connection is working and try again”. This is more correct, because it doesn't conclude that the problem is in the network connection, it only concludes that it could not reach the files. A logical explanation is that the 2017 version has separate error messages for network failure (to reach the server) and another for not being able to download, but fails in triggering the correct one.


    In any case, the solution should be very simple. Just give us the full install package of the 2016 version that was not blocked from installing in XP that was still working just fine, except not renewing its subscription. Checked for links to older versions from, none found.

  • Simon
    Simon Posts: 2,674 Superuser

    I think you will find that as F-Secure no longer supports Windows XP, you will not be able to install it on that operating system.

  • @Simon wrote:

    I think you will find that as F-Secure no longer supports Windows XP, you will not be able to install it on that operating system.

    Supporting it and allowing it to be installed are two very different things. Microsoft doesn't support XP either, but won't try to stop it from being installed with updates from its servers.


    It's also a very different situation if you are buying a perpetual license and have to read the system requirements before purchase, to this situation where it's a subscription model and there is no discussion of dropping support for a still common OS in the middle of renewal.

  • We have been given NO solution and have no working SAFE installation in the XP machine.

  • Simon
    Simon Posts: 2,674 Superuser

    Sorry, I don't wish to be rude, but what sort of solution are you expecting?  F-Secure no longer supports Windows XP, and will not install on that operating system.  That's it.  End of story.  If you want to install F-Secure, you will need to upgrade your operating system.  If it helps, here are the system requirements to run F-Secure SAFE:


  • Ville
    Ville Posts: 588 F-Secure Employee

    The reason for not allowing XP installation is very simple. Our servers were patched for latest SSL/TLS vulnerabilities. The HTTP library that our client uses (part of Windows) can't handle connections when these vulnerabilities have been fixed. Newer version of this library that came in Windows Vista works fine.


    So even if we gave out the old version it would still not work.


    Here's our KB article about XP support:



    (F-Secure R&D)



    F-Secure R&D, Desktop products

  • As the 2016 version was able to do AV updates and did never complain about a lack of network connection, do you mean that the licensing component fails with HTTPS connections in XP?


    If the problem is only in the network installers, that would still be solvable by providing a local install package as we suggest.

This discussion has been closed.
Pricing & Product Info