Problem : Redeem code not working.

Hello everyone.

Sorry to post here but the  expert chat and support isn't working.

Here is my problem, i got a 1 year subscription via a box which instructed me to go on , but this link exist anymore and when i try to add the redeem code, it's not working either. Does anyone know how to contact a F-secure member or what to do ?


Tell me which information are needed ...

Thank you in advance !




  • Simon
    Simon Posts: 2,667 Superuser

    If you go to the F-Secure home page in your country - - then navigate to the Home products, you should see a link to My F-Secure, in which you will need to register, and hopefully there will be an option to use a box code.

  • Tehpoch
    Tehpoch Posts: 5 Observer

    Hi Simon.

    Thank you for your answer.

    Unfortunately, there isn't...

  • Ukko
    Ukko Posts: 3,611 Superuser

    Tehpoch wrote:
    Here is my problem, i got a 1 year subscription via a box which instructed me to go on , but this link exist anymore and when i try to add the redeem code, it's not working either.

    Does anyone know how to contact a F-secure member or what to do ?

    Tell me which information are needed ...Thank you in advance !





    And sorry for "the up" a little be outdated topic - but just for situations if someone will be read this. And just because there missing any back-replies (so does this story was with good result and with getting ability redeem subscription code?). Smiley Sad


    With my experience such URL (from quote reply) normally redirected for valid page (?! most likely):


    Which should work as it noted under instruction-steps for F-Secure Total Security solution (I think that when you fill forms: name, mail, password - next step after entering to account will be ask for subscription code);


    But maybe it was with another design previously (but not likely);

    Also about just

    Just main page usually can be with redirect to Welcome-page.
    Where will be indeed missing 'shortcut' for "My F-Secure";

    With such situation you able switch from 'main welcome page' to Home Customers part of website;
    Or directly opening such URL: (or with your local version);

    Where will be available to switch for "My F-Secure" and if you create account there (with missing additional keys for URL) - so for redeem subscription probably you have to choose something as "Subscription/Orders" - where you able to find related button with ability fill 'subscription key' and something as 'campaign name' (which can be 'totalbox' for F-Secure Total Security or 'box' for F-Secure SAFE as example... as it can be noted under purchased Box);

     Sorry for my reply.



  • Tehpoch
    Tehpoch Posts: 5 Observer

    Hello Ukko,

    Thank's for your answer but i already tried your solution and nothing worked. I tried normal subscription code, different links etc but nothing worked.
    It's really sad to see that in 5 months, i got no answer from the F-security team. They just take the money and don't bring any support to members or should be members.


    I have rarely seen such a team to be honest. Impossible to reach them, and no one from their team connecting on the forum. This is clearly insane.


    But nevermind, i guess professionalism isn't in everyone's head, right? I just gave up on receiving anything anyway. If they can't bring any support, i don't even imagine how the application is coded and maintained...



  • Ukko
    Ukko Posts: 3,611 Superuser



    Such situations always not nice! Smiley Sad


    Sorry for my next reply.. it partly long (and sorry for my worst English). You able do not read it - if do not have time; And I still think that there most helpful should be official response from F-Secure Team (investigate) - but I decided to place there some my suggestions (and just clarification about your stuck); About support-options, license-activation-steps;




    So - maybe there will be attention from F-Secure Team (and I think that required) - but while there not yet - sorry for some of my suggestions:


    --> there available small options as Support by this URL:


    Where can be Chat-option and Phone-option (I did not use any of them - so not sure about powerful status; But based on community replies and view -> it should be useful for most common situations); Also looks like that there chat-design with changes (maybe much more friendly to users);


     --> about your stuck with activation subscription:


    But does there indeed not work steps with using next URL(?):


     When I fill there name/surname, fresh mail-address and password-form -> than choose 'Create account" -> I get (as first step of login) prompt-window with Redeem code-form.


    Where says that if I have F-Secure Total subscription - I have to add 'license/code' there. And activate it.

    If not - so - I able to use one month trial.


     Does with your experience - there missing such prompt? Or just subscription not accepted with activate-try?


    /// of course, if it still possible to check /// Smiley Sad


    --> and just as my opinion - I also can to think that with support there can be troubles (and this part - except some of 'delays' with some actions - practically one of trouble-parts of F-Secure solutions); Maybe such point based on situation that there can be small 'overload' and 'strong corporate rules' (where required approve for each step); 

    But what about quality of most of their software - it pretty good... generally (and also) if we compare to other security companies (and with meanings that F-Secure not so large company as it can be with some other top security companies);






  • Tehpoch
    Tehpoch Posts: 5 Observer

    As i said, impossible to reach the support.


    But as you pointed out, this is not so large of a company so they are more flexible, which means they should be able to react faster.

    In which world 5 months delay (To not receive any answer from their side) is acceptable from the support?

    There is just no excuse for such behaviour.


    A1) There was steps written on the packaging, but it just said to connect on the URL, nothing else.

    A2) Yeah but i filled in this redeem code and it says it's not a correct one.

    A3) I can't activate it at all, that is the problem, not a problem of waiting for some approval or something.

  • Ukko
    Ukko Posts: 3,611 Superuser

    More than some weeks (but where some weeks is a limitation) is not good design for support.


    So - if you do not mean such delay with response (receive answer) only based on community - situation is worst.

    there probably should not be any 'valid' reasons for such situation, but it should be possible to fix;


    Based on your second point - it means that maybe there required re-check license-information. So will be good for get attention from F-Secure Community Stuff (or your re-try to use support later) and their 'transfer' troublesituation for investigation. If it still valid for you.


    * what about 'not so large' status - generally about 'company stuff' and resources - than about customers or quality of software.


    And sorry else one time for my replies.




  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi @Tehpoch,


    As mentioned by @Ukko, have you tried to get in touch with our chat or phone support? I would like to know what is the issue you faced when contacting them.


    In your case, since the issue persists, I will escalate this post to our support team now. One of our agents will get back to you for further communication.


    Our apologies for the delay in getting in touch with us.

  • Tehpoch
    Tehpoch Posts: 5 Observer

    Hello Laksh,


    As we said, "better late than never", right? My only concern is to qualify a "5 months delay" by the word "late".


    As i wrote earlier, yes i tried chat and phone support, first one was said "unavailable" and second one, waited 20 min for no answer. Tried one more time and ended up with same result.

    I didn't try it for weeks/months, only for 4 days, following that deception, i tried my luck on the community forum hopping for some help and especially hopping to meet someone from your team, Laksh. I waited a couple of weeks and didn't get any answer which could solve my problem so i just gave up.

    To be honest, i totally forgot about this **bleep** but since Ukko updated my topic i realized i didn't get any answer in 5 months, which is to be honest, is totally unacceptable.


    I just wanted to point out the poor service and support brought by your firm to this story. For sure i won't ever be client of your firm following such a story, even if i paid for something i will never get.

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi Tehpoch,


    I understand your situation and the frustation you're facing. But please be assured that this post has now been escalated to our support agents.


    I am sorry to hear about the negative impact left regarding our support. And I do hope that our support team can better assist you to find a solution to your issue.


This discussion has been closed.
Pricing & Product Info