Freedom doesn't work on Windows 10 (because of driver error)

Eversince the new update (1.6.3289.0), Freedom stopped working completely for me. This is the error message I get (Windows 10 64-bit with latest updates):

---------------------------

---------------------------
<b>Driver installation Error</b>
---------------------------
Driver installation requires a reboot. Please reboot your machine and
try again.
---------------------------
OK
---------------------------


I tried restarting, uninstalling F-Secure Freedom, reinstalling couple of times, but nothing works. I also stopped all parts of ESET Smart Security just to be certain, didn't help.

The software itself starts without any issues, but with protection off. When I try to turn it on in any way, it gives me aforementioned error.

 

Comments

  • LakshLaksh Posts: 4,430 Community Manager

    Hi hipapheralkus,

     

    I found an article related to your exact error message here. Please have a look.

  • Hi Laksh,

    unfortunately, it doesn't work. I have fully updated Windows 10 64-bit (just checked for updates); and when I run the aforementioned command to see network connections as Admin, I only see my wifi and Ethernet. I don't see "FreedomeVPNConnection", nor anything similar. 

    In the Device Manager, I do see "Freedom TAP driver" version 9.0.0.21 with "This device is working properly" status. I tried uninstalling all the TAP drivers (there was a dozen of them when I tried installing Freedom again and again), but even after installation of Freedom again, and 1 driver appearing, it doesn't work.

    In the Device Manager, I can see one other Network driver: "Unknown Device", which is clearly Freedom as well. However, even when I try automatically updating the driver, it takes few minutes to finish, but without any success. It still seems like "Unknown Device". Can I upload/send Event log for this driver? Maybe it will tell you more... ".evtx" file.

    Please advise

  • LakshLaksh Posts: 4,430 Community Manager

    Hi hipapheralkus,

     

    Thanks for your update. I would recommend to contact our Support team via the Support request with the Freedome logs.

     

This discussion has been closed.