Freedome error message pops up almost every time I boot Windows

BonaVox Posts: 5 New Member

Almost every time I boot or reboot my system (Windows 7 64-bit Home Premium), I get a small error window from Freedome with the headline: "Admin permissions needed" and it says that: "Freedome needs to restart services that require administrative permissions." And it provides me with three buttons which are: Restart Service, Send error report, and Close. I have to click the "Restart Service" button twice for Freedome to start working again as normal (If I click it once, Freedome just turns off and the same error window pops on again and it starts working after the second time I restart the service. I have also sent the error report successfully twice but I don't know what the outcome of that has been. I have not tried unistalling and re-installing Freedome again because I no longer have my license key and my subscription is set to expire on July 9th, 2017.


This discussion has been closed.
Product & Pricing Info