Freedome not working in specific countries

Hello,

 

I travel a lot and have successfully been using Freedome for quite some time. Now, though, it appears I cannot connect in e.g. Indonesia and Singapore. Freedome claims that the protection is "on" but as soon as I try to browse anything there's no connection. 

 

Having said this, Freedome works back in Europe. Have the censors won in Southeast Asia?

 

Hans

Answers

  • LakshLaksh Posts: 4,424

    Hi Hans,

     

    Could you please provide more information for us rearding the issue described:

    1. Does this issue happen only in public WiFi connections?

    2. Did you have connection issues in these 2 countries when you tried to connect through any location available?

    3. Did you try to change your Wifi and see if the connection works?

  • HanselHansel Posts: 2

    Thanks for helping out!

    1. No, any Wifi connection. I have tried multiple WiFis, incl. tethering from phone to PC.

    2. I tried mutiple locations, none of them worked out.

    3. Not sure what you're asking but I refer to point 1  -I've tried at least 4-5 different connections.

     

    Cheers!

  • LakshLaksh Posts: 4,424

    Hi Hansel,

     

    I was wondering if your issue might be related to the article here. However, I have not heard of any news with Freedome not working in the above mentioned countries.

     

    Let me check and get back to you for more information.

     

This discussion has been closed.