Problem with "Turn on protection automatically" setting

Hi,

 

I'm trying Freedome trial, and it is working mostly great!

I have one big problem though:

When I turn on the "Freedome turns on Protection automatically when it starts", the internet will not work at all after rebooting - it will just try to connect forever.

 

I have

* Windows 10 10586.71, windows firewall reset to default settings, no 3rd party virus scanners or firewalls

* Asus RT-AC56U router with mostly default settings, everything enabled in WAN - NAT passthrough

 

Openvpn.log seems to have lines like 
2016-02-03 15:06:52.758 [0734.0a1c] I: RESOLVE: Cannot resolve host address: freedome-fi-gw.fd.f-secure.com:2745 (No such host is known. )  at the time of the problem.

 

Drivertool.log from the same timeframe :

2016-02-03 17:06:52.524 [1b78.17e4] *E: DriverTool::findGuidsOfTapDevices: Failed to query NetCfgInstanceId for SYSTEM\CurrentControlSet\Control\Class\{4d36e972-e325-11ce-bfc1-08002be10318}\Configuration, err:0x2
2016-02-03 17:06:52.524 [1b78.17e4] *E: DriverTool::findGuidsOfTapDevices: Failed to query NetCfgInstanceId for SYSTEM\CurrentControlSet\Control\Class\{4d36e972-e325-11ce-bfc1-08002be10318}\Properties, err:0x2

 

I am quite at loss. What prevents the VPN from starting automatically properly? It turns on fine if I enable it manually.

 

Comments

  • LakshLaksh Posts: 4,440 Community Manager

    Hi freedoms,

     

    Does this issue with the internet connection occur only after your computer restarts? Have you enabled the option ' Freedome starts automatically after you restart your computer'?

     

    How about the time in which your computer sleeps and after wake up, does Freedome have issues in reconnecting back?


  • @Laksh wrote:

    Hi freedoms,

     

    Does this issue with the internet connection occur only after your computer restarts? Have you enabled the option ' Freedome starts automatically after you restart your computer'?

     

    How about the time in which your computer sleeps and after wake up, does Freedome have issues in reconnecting back?


    Case 1: Reboot when ' Freedome starts automatically after you restart your computer' OFF

    Result: Internet works OK. If VPN is enabled manually, it connects correctly.

     

    Case 2: Reboot when ' Freedome starts automatically after you restart your computer' ON

    Result: No internet connectivity. Freedome stuck at "connecting", unable to turn freedome to OFF position, to get internet working again I have to turn the automatically protect setting off and reboot.

     

    Case 3: Resume from sleep when Freedome is ON but ' Freedome starts automatically after you restart your computer' OFF

    Internet conenction resumes normally after sleeping after freedome connects.

     

    Case 3: Resume from sleep when Freedome is ON and ' Freedome starts automatically after you restart your computer' ON

    Not tested

  • LakshLaksh Posts: 4,440 Community Manager

    Hi freedoms,

     

    Thanks for the detailed information. Does it happen with all the locations, irrespective of what location you choose?


  • @Laksh wrote:

    Hi freedoms,

     

    Thanks for the detailed information. Does it happen with all the locations, irrespective of what location you choose?


    I did not try all the locations, but I tried several and none of them worked. 

  • LakshLaksh Posts: 4,440 Community Manager

    Hi freedoms,

     

    I would advise to better open a support ticket as this might need further investigation from our Support team. Please open a ticket and provide all the details.

This discussion has been closed.