Continuous "Connecting"

My Freedom ststus keeps saying connecting and has been for 2 days now - I am not getting the protection I need ?  

Best Answer

Comments

  • LakshLaksh Posts: 4,440 Community Manager

    Hi IrishPhilip,

     

    May I know what is the OS of your device in which Freedome is seen as connecting? Is the Freedome subcription still active?

     

    May I know how you purchased Freedome and if this is the only device having Freedome installed?

  • Hi I am using OSX 10.11.2

     

    My subscription is pretty new and it has been working - I am also using Freedome via my iPhone but that was bought last year.

     


    @Laksh wrote:

    Hi IrishPhilip,

     

    May I know what is the OS of your device in which Freedome is seen as connecting? Is the Freedome subcription still active?

     

    May I know how you purchased Freedome and if this is the only device having Freedome installed?


     

  • Dear F Secure team - I am trying to get some help - so far of my subscription time I am getting virtually not time witha secure connection ?  What is the point - where can I go to get a little bit of human assistance to ensure my configuration with your product works.... at the moment it isnt....  IP


    @IrishPhilip wrote:

    Hi I am using OSX 10.11.2

     

    My subscription is pretty new and it has been working - I am also using Freedome via my iPhone but that was bought last year.

     


    @Laksh wrote:

    Hi IrishPhilip,

     

    May I know what is the OS of your device in which Freedome is seen as connecting? Is the Freedome subcription still active?

     

    May I know how you purchased Freedome and if this is the only device having Freedome installed?


     


     

  • LakshLaksh Posts: 4,440 Community Manager

    Hi IrishPhilip,

     

    Have you tried to change the locations on your Freedome and retry the connection? Does it work?

    Is your Freedome subscription on OSX 10.11.2 directly purchased from F-Secure?

     

    If you are still having the issue, I would recommend to open a support ticket so that it can be investigated further.

This discussion has been closed.