Freedome won't start

Tried to upgrade to the latest version this morning. Got a message that something went wrong. I can't switch it on. System is Windows 7 on an old laptop.

Comments

  • Hi!

     

    Same issue for me, win 7. Freedome can not be turned on anymore and reinstallation fails. 

     

    BR,

    Edmund

  • LakshLaksh Posts: 4,439 Community Manager

    Hi @Buckman and @Pauli1,

     

    May I know what is the version of Freedome which is currently installed on your computer? Do you see the error 'Something went wrong' when you try to turn on Freedome?

  • My version is 1.0.1145.0. I booted the machine twice and now it works ok.

  • Hej,

     

    I rebooted a couple of times and now it works!

     

    BR,

    Edmund

  • Hi Laksh,

     

    If you are still available on this one it would be grand. My Version is Freedome  1.0.2352.0. Love everything at F-Secure, just like I love insurance policies, however, after Freedome worked sweetly for the first week (maybe after an update, don't know) my system [secured under F-Secure Internet Security] has refused to allow Freedome to open independently with lots of crashes. I can only get it to work by quitting it and restarting it. Any suggestions? I have one. My reckoning is that Microsoft has sequentially pursued a policy of making Windows 7 less stable as it prepares the ground to cast it off and F-Secure, not just has to, but rather must follow the trend and requirements of Windows 10, thereby putting Windows 7 users into a 2nd class customer ranking and that this will mean increases in software malfunctions across the platform unless users stick to legacyware. Correct?

    Image:  <An example of one...> One of the systems statements - others have included, "Freedome has failed to acquire systems authorization and cannot start." And, "Restart Freedome" ... Blah, blah - failure. This happens everytime I start my system. 

  • LakshLaksh Posts: 4,439 Community Manager

    Hi @Crikey,

     

    Could you please check the articles here (this one is mainly for Windows 10 upgrade but the error is the same) and here for this issue? Please try the steps given for the IPv6 error.

This discussion has been closed.