Freedome keeps giving an error after update - Using Win10 - because of that ran out of licenses.

Having issues with Freedome, since the last update im getting errors, running on win10, freedome version 1.0.1842.0, also tried with the last beta (1.0.1897.0) and same behaviour.

 

And now because of that i uninstalled freedome and ran out of licenses, need some assistance from any f-secure advisor to solve the situation, or at least get my license fixed, so when freedome gets fixed i can continue using my license.

 

Thanks a lot.

Comments

  • LakshLaksh Posts: 4,442 Community Manager

    Hi Xtremed,

     

    Could you please let us know the error message you are seeing with the Freedome update (a screenshot might help)? Does the error message happen when turning on the Freedome/ when installing the update?

     

    Regarding your license code error, may I know from where did you purchase your license for Freedome? Is it a single license key or a multi license key? If multi license key, may I know how many licenses are available for the code?

  • Im not at the computer right now, but it just says "Error: something went wrong" when i click connect (it happen the same in several locations), and i already sent a report and everything, so it seems the same error everybody is having from the recent update, i remember that usually the VPN use to show as an alert in the notification center that it was active, so not even that happens.

     

    I have the Freedome license from SAFE, so i think its 3 licenses for me, and some to share with friends, but after uninstalling several times Freedome i lost those licenses, it doesn't detect is the same device.

    If you need i can provide the Code via PM, later, just let me know if you need anything else.
    Thanks.

  • LakshLaksh Posts: 4,442 Community Manager

    Hi Xtremed,

     

    Regarding your license issue, have you used all your 3 codes from Freedome (from your safe account) on 3 different devices? What are the other devices using Freedome codes apart from the Win 10?

     

    Do you still have a license from Freedome (in Safe) which is unused?

  • Well i reinstalled the same code (for my own device) into my computer 3 times and then i ran out of licence, first i have it on win 8.1, did a clean install of windows 10, 2nd use, then uninstalled freedome, to check if that fixed the problem, 3rd use... uninstalled and used beta, gives me the error i ran out of keys, and then i just need to use the one to send to my friends.. (Which i don't want to do.. i want to use my personal license instead) let's hope we can manage a way to reset the licence, again. Thanks!, PS: i will send the FSDiag as asked on the PM later.

  • @Laksh wrote:

    Hi @Xtremed,

     

    Regarding your license issue, have you used all your 3 codes from Freedome (from your safe account) on 3 different devices? What are the other devices using Freedome codes apart from the Win 10?

     

    Do you still have a license from Freedome (in Safe) which is unused?



    Hi Laksh, im still waiting for a solution to my license problem, i already explained the situation in my previous post, any help?

     

    freedome_license.png

  • LakshLaksh Posts: 4,442 Community Manager

    Hi Xtremed,

     

    I have sent you a Private Message for the license code issue.

  • LakshLaksh Posts: 4,442 Community Manager

    Hi Xtremed,

     

    We have inspected several cases where Freedome has been unable to make VPN connections after Windows 10 upgrades. The symptom has been an error message saying only "Something went wrong. We're sorry." when Freedome has tried to make a new VPN connection. The problem has appeared right after the operating system has been upgraded to Windows 10. We are aware of at least one case where the problem was fixed after Windows 10 was reinstalled on the computer.

     

    Based on our inspections it seems that the operating system has been in a similarly problematic state in each of these cases. While we haven't been able to reproduce this situation in our test environment, our best estimate is that something has gone wrong in the Windows 10 upgrade and has caused these problems.

     

    From the error messages in the Windows log files it is apparent that also other applications have various technical problems on these affected computers. These error messages can be seen using Windows Event Viewer. You can open Windows Event Viewer by clicking the search icon on Windows 10 Task Bar and typing "Event Viewer" there. The logs reside under the "Windows Logs" entry.

     

    We currently recommend to reinstall Windows 10 on the affected computer. However, we are still inspecting if there would be any alternative ways to get Freedome to work in this kind of situations.

  • Hey thx for the feedback, something that i wrote on the other posts, and maybe its related with the whole issue:

    After installing the last update the driver just dissapeared, so my guess is that there is an issue with that, that's why it fails, if you go under network connections you wouldn't see it.

     

    It was also mentioned in this post.

    https://community.f-secure.com/t5/F-Secure/Windows-10-problem/td-p/74476

     

    So maybe that could work, if we can find a solution to re-install the driver that could solve the problem, also if its possible can send me the previous version of freedome to give a try?

    Thanks for everything.

  • LakshLaksh Posts: 4,442 Community Manager

    Hi Xtremed ,

     

    I have passed on your feedback to our team. If I have an update, I will get back to you soon.

  • XtremedXtremed Posts: 10

    Hi Laksh i solved the problem.

     

    As i pointed before... the whole issue it's related with the FreedomeTAP driver:

    I went to the Freedome\1.1\driver-x64 folder, and replaced the tap0901.sys with the updated driver from openVPN ver. 9.0.0.20, then manually added legacy hardware to the computer using the device manager, and installed the FreedomeVPN driver.

    Now it works like a charm, please forward this solution to your tech team, so they can push an update in the next version, including the right OpenVPN driver.

    If you need any info or a zipPackage with the driver just let me know.
    Thanks.

  • Great news!

    I would like the zip package please :) Can't find the correct driver.

     

    Best regards,

    Tobias

  • thiepsthieps Posts: 2

    Hello. I have the same problem. Can i have the zip too? Thanks. Thierry

  • thiepsthieps Posts: 2

    Hello,

    A lot of people, perhaps everybody on Windows 10, has the same problem since a long time ago. What make FSecure to resolv this problem? This is very bad for the reputation of Fsecure. I'm sorry, but with this experience, i will never try again a software of FSecure. Thierry

This discussion has been closed.