TP135 Windows Client Release

VilleVille Posts: 522 F-Secure Employee

FS Protection PC Release 135


  • Common Component Framework 2.35 build 272
  • Antivirus 14.135 build 100
  • Browsing protection 2.135 build 3356

New features

  • Changed hardware requirements. Pentium 4 or equivalent is now required for this product (SSE2 enhanced instruction set support to be exact).
  • Support tool has been updated. It now runs faster and creates smaller packages.

Fixed issues

  • "Try again" text truncation in some languages (es, nl, pt) (CTS-96011)

Browsing Protection:

  • Banking Protection blocks public DNS (CTS-96061)
  • Untracked issue with device lock blockpage timer

System requirements (changed)

  • Processor: Intel Pentium 4 or higher.
  • Memory: 1 GB or more.
  • Disk space: 1.2 GB of free space.
  • Internet connection is required in order to validate your subscription and receive updates.
  • Javascript must be enabled in the user's browser settings to enable active block pages.




  • SimonSimon Posts: 2,661 Superuser

    I have an Intel Core 2 Duo E6750 CPU.  I have no idea how that compares to a Pentium 4, but I guess I'll soon find out... 

  • VilleVille Posts: 522 F-Secure Employee



    Basically Pentium III or older will not work. It's a bit harder to say for AMD processors. Any 64-bit processor will support it automatically. Core 2 Duo will be just fine.



    (F-Secure R&D)


  • SimonSimon Posts: 2,661 Superuser

    Hi Ville,


    Well, it's installed and up and running, so it must be OK.  :)


    Just tried the support tool, and it zipped up to 55% in a few seconds, then seemed to stall for about a minute before continuing.  Took around 90 seconds in total, which is definitely quicker then before.

  • VilleVille Posts: 522 F-Secure Employee

    Hi Simon,


    The installer and upgrade both check the CPU before allowing to continue. You would have received an error about unsupported CPU. Anyway, SSE2 was introduced in 2001, so it's quite rare not to have support for it.


    In my tests support tool was always running in about 20 seconds. Oh well, this is what happens when software hits real world...  The speed was not the main point, the main benefit should be smaller package size. Some users would get huge (over 30MB) archives with the old tool.



    (F-Secure R&D)


  • SimonSimon Posts: 2,661 Superuser

    The package size is 2.52MB.  I've just done another, which still paused at 55%, but not for so long this time, and the process completed in about 40 seconds.  This is on a 2007 machine, with a lot of stuff on it, so most things tend to run a little less optimally than what would be expected on a more modern device.  I'll try it on my new (ish) laptop later, for comparison.

  • klima89klima89 Posts: 58

    All updated without any problemsSmiley Happy

  • SimonSimon Posts: 2,661 Superuser

    Just tried support tool on Windows 8.1 laptop.  Result much the same.  First run took 80 seconds, with a 40 second pause at 55%.  Second time took 50 seconds, with a 20 second pause at 55%.

  • UkkoUkko Posts: 3,217 Superuser



    Sorry for my reply.


    My experience about new Support Tool will be next:


    -> Originally my device and new Support Tool create a fsdiag after: 

    One Minute (and related with load under system -> ten or twenty seconds).


    -> Step before prepare to zip-process (potentially it's about Fifty-Five% check point).... about Ten Seconds.

    Step during or start "zipping" (?) about Thirty Seconds (related with load -> can be a little be less or more).


    -> And last steps (with creating fsdiag under desktop) goes be around Thirty Seconds too.


    It's about first "run" for Support Tool.


    But I'm also able to get about twenty seconds... and it will be about all next "run"-launch-action for Support Tool after first one per session (?!) or time-point.

    I check it around ten-launch-processes.....

    All of them goes be around Twenty Two Seconds (second less, second more).

    With step before "prepare to zip-process" - about Three Seconds.

    "Zip-process" as potential launch or ?! - about Two Seconds.

    And... last steps (after fsdiag-created under desktop) as potentially finally compressed... ... about Eighteen Seconds.




    Also.. size of fsdiag under current system will be: 4.27Mb (and original size is 141Mb);

    Previous Support Tool.. If I normally remember... was about  (same system) 16Mb (and original size is 221Mb);




    Some of launch-actions was with a little be different background (such as.. I tried to use "network disable" or various load for system) - not sure.. can it's be important, but time can be less/more (a little be). And size for two of ten fsdiags.. a little be more, than other.


    But it's... totally and certainly work more speedy... and create less-size for zip-archive.



  • VilleVille Posts: 522 F-Secure Employee

    @Simon @Ukko 


    Thanks for the test results. Overall looks like it takes a bit longer to run that I expected, but it's still improved. The old one typically took about 4 minutes to run.


    The switch from preprocessing to compressing typically happens between 50% and 60% but it's not hardcoded and depends on how much there is to preprocess and how much to compress. If there is long delay, it is probably waiting for some external executable to finish (ping, netstat, etc).


    It's good to see that the archive size went down by 75% on Ukko's test.



    (F-Secure R&D)


This discussion has been closed.