F-Secure Blocks Game (Payday 2)

OS: Windows 7 Home Premium

So basically, i recently bought Payday 2 off of steam. I loaded up the game and everything is great. Couple days later, it crashed. I then noticed on ym second monitor that a pop-up window came up from f-secure asking if i trust this program as it was being monitored by DeepGuard. I tried clicking on the window HOWEVER no matter what i try i cannot get the window to be clicked on. It crashes the game, while the window is still open and the pop-up stays behind the game window being unable to be moved or clicked. This is extremely irritating. I tried changing application permissions, but it does not show up in thier at all after searching through EVERY application it is monitoring. This bug/glitch happens when i play the game lets say after about 2 hours or so. It can sometimes happen just as soon as i load up the game though. If needed, the text in the pop-up window only asks if i can trust the application to connect to the internet (which of course i can). Please help, and thanks.

Best Answer

Comments

This discussion has been closed.