Freedome app says connected to the UK but is stuck in connecting mode

My android app was okay until I updated it yesterday. Now it says it is exchanging packets of data with the UK server (from Spain) but it has been stuck on 'connecting' for hours and not moving on to 'Protection on' and the services I'm trying to connect to are not working.

I've tried uninstalling and reinstalling the app but it makes no difference. Trying to connect to another location, even Spain, is the same. I have a subscription, which  it confirms is valid.


Does anyone know what can I do to fix this now?


  • shard
    shard Posts: 5

    The problem continues 24 hours later...  I think it must be to do with the app (V 2.0.7. 1878) rather than my Android Netbook setup because I installed and successfully used the free trial of an alternative app, UK VPN.


    I uninstalled and re-installed Freedome again, but it still doesn't makeany difference.


    Is F-Secure providing support for people with subscriptions?

  • shard
    shard Posts: 5

    I'm now back in the UK and so will not be able to test any solutions that anyone might suggest, but I'm still interested to hear any in case the problem continues (as I suppose it will) on my return to Spain in a few months.

  • Tapsa
    Tapsa Posts: 82 F-Secure Product Expert



    Sorry for the delayed response.


    There is a bug in Android 5 (Lollipop) which could cause this kind of behavior. A reboot of the device should fix the issue; have you tried rebooting yet? 


    You can test the product equally from the UK. When you connect to our UK virtual location from the UK, all your traffic will be routed through our servers in UK in the similar fashion as it would be routed should you be still in Spain.


  • shard
    shard Posts: 5

    Hi Tapio,


    Thanks for the suggestions. Unfortunately my netbook is still at our place in Spain so I can't test it from the UK.


    Also, the version of Android is Jellybean 4.1.1 - Kernel 3.0.8. As I said, the app connected until I updated the app last week. As the rest of the app appears to be funtioning, and this doesn't seem to be a general problem for your users, and the alternative VPN app is connecting, I'm wondering if there could be some blocking happening at the router?



This discussion has been closed.
Product & Pricing Info