Cannot install F-Secure Anti-Virus on Windows 8.1

My friend bought a new Lenovo Yoga 3 laptop so I uninstalled  previously installed McAfee Internet Security and ran the McAfee Cleanup tool then disabled Windows Defender. After launching the networkupgrade exe I got in the email I get an error saying "F-Secure Internet Security upgrade failed uninstall previous installation first". There is no previous installation of F-Secure and why does it say F-Secure Internet Security in the installer we downloaded the AV installer!

 

Please help now I feel like an idiot after having had praised F-Secure and recommending it for her!

Comments

  • SimonSimon Posts: 2,653 Superuser

    I'm not sure whether this is correct, but this would appear to be a link to the AV installer, however, it looks to me to be the same as the one for Internet Security  http://download.sp.f-secure.com/SE/Retail/installer/F-SecureNetworkInstaller.exe.

     

    As for the error, I would suggest you run the McAffe uninstaller, which you should be able to find in this list of Uninstallation Tools, as maybe the cleaner you used left something behind?

     

    If you still have problems after that, then try the F-Secure Uninstallation Tool so as to start with a clean slate, and then run the FS installer again.

     

     

  • Nope, that didn't work, the McAfee Uninstaller is the same one that I used. I ran the F-Secure uninstller then ran the F-Scure Network installer and again it said that there is a previous version already installed when there isn't.

     

    The way I solved it is by downloading the Network Installer from this page:

     

    https://www.f-secure.com/en/web/home_global/downloads

  • VilleVille Posts: 515 F-Secure Employee

    @MatrixLeader 

     

    You said networkupgrade.exe, which is different from the installer name. Did you get a different installer in e-mail? Also did I understand correctly that the problem is solved now by using the installer from the downloads location?

     

    @Simon 

     

    The installer is the same for AV and Internet Security. The common components are same for both products. After you enter keycode, it will download and install different applications based on the code.

     

    Ville

    (F-Secure R&D)

     

    MatrixLeader
  • SimonSimon Posts: 2,653 Superuser
    Thanks for clarifying that, Ville.
  • Yes sir, the downloader which the lady I recommened to buy F-Secure sent to her email didn't work, it kept giving the error that F-Secure is already installed when no AV is installed, Windows Defender is disabled. First I thought maybe after we run all the Windows updates it would work but it didn't. Then it only worked after downloading the downloader from the link I mentiond in my previous post.

     

    Please fix this as it doesn't reflect nicely for a new customer

  • Yes! Definitelly, there is a conflict between FSIS2015 and Windows 8.1 after its latest system updates.

    I tested it instaling three times Windows 8.1. At the beginning FSIS worked corectly but after I updated the operating system FSIS has began giving constant error messages that both it and Windows Defender are off. It is a proofed fact.

    It does not metter wich FSIS installer you used for installing of the AV. For an hour after the OS startup multiple instances of "MpCmdRun.exe" (normally two) appear in Task Manager "eating" CPU power more than 40% each. The check shows that no update of FSIS2015 and OS is performed during that time and more than 45 minutes later the sytem gets retively calm, and System Idle Process sits on ~90%. FSIS GURUs do something, please!

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Ivbosh,

     

    It seems that you have a slightly different issue, as the installation completes.

    MpCmdRun.exe is related to Microsoft Security Essentials.

     

    Could you make sure it is not installed?

This discussion has been closed.