F-Secure Freedome VPN 2.0.5 for iOS released

Tapsa Posts: 82 F-Secure Product Expert

F-Secure Freedome VPN has had severe VPN connection problems on the new iPhone and iPad operating system, iOS 8.0.0 and 8.0.2. While these connection problems have affected only a small part of our users, they have been severe for those who have been affected.


After fixing some issues in our own app we found also a bug in the iOS operating system. Based on our investigation, this problem with dropping VPN connections originates because of this bug. Apple changed the VPN interface significantly between iOS versions 7 and 8. This bug is not present in iOS 7. We have filed a bug report at Apple about this issue.

However, we found a workaround to the iOS operating system bug. Starting from F-Secure Freedome VPN 2.0.5 (released on October 14th), the VPN connections are stabile again. We have received positive comments from a number of our users already; according to the feedback the connections are not dropping any more with this version. This version is already available through the App Store and is offered as an update to the existing users.


There are still two things you should manually check on your iPhone or iPad with F-Secure Freedome VPN 2.0.5:


1. Please open the device Settings/Common/Profile and check that there is no configuration profile titled "F-Secure Freedome (iOS7)" any more. It may have been left there after you have upgraded the operating system to iOS 8. If the profile exists, you should open and delete it. If it exists, it may cause problems with the VPN connections.


2. After you've upgraded to F-Secure Freedome VPN version 2.0.5, please open it and turn it once ON from the "ON/OFF" toggle in the center of the screen. This ensures that the device is running the newest version of our product and that it is turned on.



  • Hi,
    Thanks guys, very good workaround and more stable version this time. Some events still make short breaks to the connection, but it may be related to the iOS bug. VPN connection resumes very quickly. Most important for me is that I can use Freedome again after long time and it works! Not perfectly but good enough. Maybe iOS 8.1 will bring back same stability what we got used to with iOS 7.

    Thanks and Regards,
  • Updated to iOS 8.0.2 (on an iPad)
    Updated Freedome to Version
    Had been using Device Control
    Install advised removal of Profiles (used by older version). Did that.

    Freedome is OFF
    “No virtual location in use”
    “You have enabled Device VPN control.”
    “To control VPN, go to your device Settings and select VPN”
    Nope! VPN disappeared from Settings after removing Profiles (as advised by Install)

    “To restore control to Freedome, turn off  Device VPN control in the app settings. (Freedome > Sidemenu > Settings)”
    Nope! The only option in Sidemenu > Settings is “Usage statistics”


    What now?


  • Tapsa
    Tapsa Posts: 82 F-Secure Product Expert

    Most likely there is something wrong with the configuration profile in the device settings. Could you please open Settings -> General -> Profiles. Remove the F-Secure Freedome profile there and launch our Freedome app. It will recreate the profile.

    Please let us know if this helps.
  • Hi,
    This morning I updated both my iPad and iPod to iOS 8.1. Really dramatic improvment for stability for both WiFi and Freedome connection. No more short breaks that dirsturb applications and straming video. I have done very intensive testing the whole day and I'm pretty sure that these issues are now solved for good.


  • Hello,

    1) Profile already deleted.

    2) No sign of a 'Turn off Device VPN' in the Freedome -> Sidemenu -> Settings


    Before the upgrade,

    Settings -> VPN had a list of country locations

    Settings -> General -> Profiles had a Freedome entry


    During the install of the new version, an advice came up to remove the Profile as 'the old settings might cause some problems for the new' (that sort of wording)

    I removed the Profile and continued the install.

    That seemed to remove the Settings -> VPN  list as well.


    There was an additional Profile present for a HMA VPN ( which I flirted with a while back, but don't use).

    That was still present when I continused the install after removing the Freedome Profile.

    I deleted that Profile after seeing the problem that I described in my first post.

    Perhaps teh presence of that Profile caused some confusion?


    Perhaps I should completely remove Freedome and reinstall.

    I did try 'Restore Purchase' - but no effect. That seems to be a synch with other device versions - so I didn't really expect a change.


    I must confess to being a Freedome Freeloader :)

    I'm on a trial version that expires November 26th. Buying a licence a bit earlier isn't the end of the world.








  • hi
    i just bought this vpn for two days and a year license. what can i do ?
    it does not work. i installed ver 2.0.5.

    my ios ver is 8.1. vpn does not work on iphone 6 only after 2 days.

    i paid 29 $.

    it is not right to abandon us......

    please help me????
  • Tapsa
    Tapsa Posts: 82 F-Secure Product Expert



    With just this description it is difficult to analyze what the problem is.


    Could you please describe the problem in more detail?


    - Do you see any error messages? If yes, what do they say?

    - Does the Freedome app say that it is on or off? If it says it is off, what happens if you try to turn it on?

    - Are you able to get any data traffic through, or is this related only to some apps on your iPhone?

    - Which virtual location you're using and have you tried other virtual locations to see if that helps?

    - Where you're connecting from?

    - Does this problem occur when you're connected to a WiFi network, 3G/4G phone network or both?



  • At first it is unsigned profile thenit says you must restart your phone to ressolve this issue. It is a rare problem in ios 8,
    When i want to change virtual location it does not change anything.wifi or 3g does not matter. Only one time it worked on 3g. I live in iran. But default virtual location is hong kong. On or off toggle always spinning and vpn in settings menu always show connecting'
    And it disrupts normal operation of internet in phone. When i used free version it was working perfectly so i bought one year licence and after that .... Youknow, please help
  • Tapsa
    Tapsa Posts: 82 F-Secure Product Expert



    To investigate this further, we need more information from your Freedome app. I've contacted you with more details in a private message, please check your private messages and please get back in touch.





  • SamK
    SamK Posts: 4
    Hi! After updateing to ios 8.1 i'm experiencing exactly same symptoms as parannoyed. Can't switch the VPN on.

    I have purchased this licence and the side settings in the app are quiet empty of content after deleting the old 7.xx vpn profile.

    Thanks for good advises in advance.

    Br Sam
  • SamK
    SamK Posts: 4
    Ok, this problem is history. I did remove the app and re-installed it. Now it works well.

    Thanks for your advices, im still struggling with the missing cookies....

    BR Sam
  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee
    Hi hossein!

    I noticed that you posted this same issue in another thread. Have you replied to Tapsa's private message? Are you still having this problem? Please let us know!
  • hi
    i have this problem

    it never solved. i sent the log file and ...... please solve this or just give my ,money bavck,,,, thanks
This discussion has been closed.
Product & Pricing Info