Problem with real-time scanning



I have updated to the new OSX Yosemite. After the update I have some problems with the real-time scanning. It dosen't work. It says that the Mac is NOT protected against virus. Can some people help me, before I have to buy another virusprogram for protection?


Sorry for my bad english :)

Accepted Answer


  • NikK
    NikK Posts: 935 Rock Star

    Supported Platforms for Anti-Virus for Mac doesn't mention Yosemite. So either it's not supported, or maybe it is supported but that page hasn't been updated. I'm not sure so I hope the F-Secure team can help out here!


    You could try to uninstall and reinstall the product and see if that helps. Uninstallation Tool:

  • Chrissy
    Chrissy Posts: 438

    Hi stmana!


    Have you tried the re-install, or has anything else helped?  Or do you still need our advice?  Please let us know! :)

  • Hello, just wanted to report to the F-Secure world that I am on Yosemite beta and had the same problem


    Uninstalled and then downloaded and reinstalled and I'm good to go

  • Hi. Im currently running OSX 10.9.5 and just updated my f-secure. Now the real-time scanning does not work and Im not protected. What to do?


    Sincerely Asbjørn

  • Now Yosemite is officially realeased. When do we get update for the the F-Secure?

  • pajp
    pajp Posts: 86 F-Secure Employee



    It seems that the Yosemite upgrade deletes a folder essential to our software. The easiest way to resolve the problem is to re-install the application.


    If you're familiar with Terminal, you can also fix the problem by running the following command as an admin user (you will need to supply your password):


    sudo mkdir /usr/local/f-secure/fssp/var/update/

  • Thanks! This solved the problem : 

    sudo mkdir /usr/local/f-secure/fssp/var/update/


  • Works Like a Charm. 

  • just up dated to yosemite on mac now real time scanning not working any ideas

  • Same problem here- The rotten apple again... any solution out there, or should I just move back to windows?

  • uninstall f-secure then re-install and it all works



  • Ben
    Ben Posts: 2,641 F-Secure Product Expert

    This post sums up the current solutions available.

  • thanks all sorted

  • Ben
    Ben Posts: 2,641 F-Secure Product Expert

    A fix is now in place so that the problem shouldn't occur anymore.


  • Solved
  • We are in the same boat, the recommended solution of mkdir: /usr/local/f-secure/fssp/var/update/ does not fix the issue. The F-Secure client still shows as unregistered.

    I've proven this by creating this folder after the Yosemite upgrade with the above terminal command.

    I am in an organization that has hundreds of client machines to upgrade so I would need something thats automated or just works from F-Secure themselves. Please advise
  • pajp
    pajp Posts: 86 F-Secure Employee



    the latest F-Secure products should all support Yosemite. If you're still having problems, please contact support through this form: - attach the output of Support Tool so that we can diagnose the problem. Your description of the problem "client still shows as unregistered" suggests that this may be a different issue from the real-time scanning problems related to Yosemite upgrades.

This discussion has been closed.