Freedome losing internet connection

Running subscription Freedome, my device reports "no internet connection". When I turn Freedome Protection off (from the blue spherical Freedome screen center) and then turn protection immediately back on the internet connection works fine for some limited time. 


Example: I open Spotify. I receive "no internet connection" message from Spotify. I turn Freedome protection off and back on. Spotify can now play a song. After song completion the next song fails with "track failed to load", most likely caused by missing internet connection. 


Problem appears with my devices Nexus 5 and Nexus 7. Problem apprears with multiple WLANs on multiple different locations and also with cellular data. Other devices using the same WLANs  but not Freedome work fine. 


What can I do to solve the problem?



  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello @vms ,


    Is your problem limited to Spotify or other specific apps?

    Is normal browsing also failing after some time?


    Spotify seems to have geographical restrictions on some of their content, which could explain such behaviour.


    Also do you have the same issue when you use the location corresponding to your own country in Freedome?


    PS: I also moved your post to the relevant board.

  • vmsvms Posts: 5

    Problem is not limited to Spotify. All apps that require internet connection seem to share the problem. 


    Normal web browsing (chrome) also suffers from the problem. 


    I have the problem using the country corresponding to my own country. 


    Additionally: The problem has been around for some weeks now. When I first started using Freedome I never had this issue. 

  • JaysonJayson Posts: 595


    May I know which Android version you are having on these Nexus devices?


    Do you by any chance have a PPTP VPN account you could test to add VPN manually? Please let me know how it goes.



    Best Regards,

  • vmsvms Posts: 5

    I use Android versions as Goole pushes them out, currently 4.4.3. 


    I have no idea about PPTP. 


    I recently discovered the "Make bug report" feature. It produces massive ammount of data. Are there any keywords or suspicious items that I should be looking for in those reports? I think I will next try to record time of problem occurances and search any info related to those times from the bug report. 

  • ChrissyChrissy Posts: 438

    Hi vms,


    Did you have any luck on your own trying to troubleshoot this, or do you still need a hand from our side?  If it's solved, please let us know what you did!



    // Chrissy

  • vmsvms Posts: 5

    I have narrowed my problem down to... well, if I keep a streaming radio station open, I seem to have a stable netword connection. If I do not, the chances of losing network connection increases. 


    Some recent software update (Android operating system or Freedome) seem to have also decreased the chances of this problem occuring. It's much less troublesome now. 

  • ChrissyChrissy Posts: 438

    Thanks for the update, and good to hear that the situation has improved in some ways!  Please let us know if you get any more insight to this, or if new problems arise.




    // Chrissy

  • PatmanPatman Posts: 12

    I am also having these problems and I have to disable the Freedome VPN connection to get my browers working again. Do you have a fix yet?

  • Lot of problems today. Connection to Espoo jump on and off.

  • LakshLaksh Posts: 4,444 Community Manager

    Is the issue still persisting today or has it been resolved now? When did the exact issue happen with the Espoo location?

  • Today no connection issues.


    Yesterday afternoon -1hrs - +5hrs previous post time. Connection on and off about every 10 minutes.

  • Hi ....I spoke to someone from F-secure on twitter today and told them about the problem i was having with freedome ....they advised me to come on the community site and ask there about my problem with 'freedome'..... I had a four or six month trial and i deleted it (after about six weeks ) it started away fine and blocked nearly 90,000 sites who were trying to track my computer , its a great idea i would say....but ...after a while it stopped me getting into my usual sites and i had to switch it of to do so.

    I have now downloaded windows 10 and wondered if it the issue i had with freedome is sorted out now or do you think widows 10 will  make a difference ?

    Can i try it again or would i need to join up and pay the fee for the use of freedome , as i said, it was great for the first few weeks and i was intending to purchase 'freedome' when my trial run out .

    I have nothing but praise for F-secure and will continue to use the anti-virus which i have done for about two years now .

    Thank you


    seanchai .

  • PatmanPatman Posts: 12

    I am having the same problems as you and I have a paid up subscription. I think that was a lousy lazy answer and I would expect a better reaction than I have had so far to my problem. Reaction so far? Zero

  • Hi Patman ..... sorry to hear that you to are having problems with Freedome ....but on the other hand i am quite relieved that i am not the only one who is having problems (i don't mean that in a bad way )...

    F-secure were advertising "freedome" on twitter earlier today and i mentioned to the poster that i had been having problems and they pointed me in this direction (ye know what its like on twitter...if thats what you mean by a lazy answer my friend ) ....i could only get a few words in ...and they were the same so i take it that is why they pointed me in this direction . I would certainly be more annoyed if i had paid the subscription and it was not working , I like F-secure anti-virus and thats why i tried 'freedome'....

    If i hear anything directly i will let you know Patman ....and likewise ,if you hear anything please drop me a post .

    Thank you ....and i hope you get things sorted out soon .




    PS... i kinda thought the goverments (of various countries ) would not take "Freedome " in their stride ...its is certainly not suiting them not being able to follow our every move .

  • LakshLaksh Posts: 4,444 Community Manager

    Hi seanchai,


    Thanks for your feedback on our products.

    May I know which particular location were you selecting when connecting through the Freedome VPN? Have you tried using the other locations and does the same issue occur?

    However, regarding the installation, may I know how many licenses does your mentioned 4-6 month trial hold and till when does your trial remains valid? You can check more information about the code for Freedome in the link below:

  • LakshLaksh Posts: 4,444 Community Manager

    Hi @Patman, Sorry to hear about your inconvenience!


    May I know what is the OS of your device in which you have the Freedome installed? Does this issue occur on all the browsers or does it occur with only one browser?


    Since you mentioned that the browsers can access the internet when you disable Freedome, could you try to change the locations and see if the issue repeats? Or is it related to one location only?

  • PatmanPatman Posts: 12

    Hi, the OS is Windows 7 and it occurs with Google, Firefox and IE. I've now re-enabled Freedome and although it seems to be taking slightly longer than normal to load pages, they are loading. My location is set to London and I am in the North-West of the UK. I guess I'll just have to monitor it unless you have an update on the issue.

  • PatmanPatman Posts: 12
    I've disabled Freedome again. I couldn't get through to and as soon as I disabled Freedome the page loaded instantly...
  • Thanks for your prompt reply Laksh.......I,m sorry but i have no record of my trial start/expiry date , i had 'freedome' on my computer for around two to three months (as far as i can remember)at first it seemed fine   ...but after a certain period of time i could not get into various sites like my yahoo mail ect.....i then disabled Freedome and then i could get into the sites ok....i did this at various times and in the end i deleted  'freedome' altogether ..    my browser has been fine  after that and i have had no bother since i  .I have now downloaded windows 10 and wondered if it would make any difference with the problems i have had with Freedome, of course i would not purchase 'freedome' until i knew it was going to work ok as it seems that i am not the only one who had problems with 'freedome'.



  • vmsvms Posts: 5

    @Patman wrote:
    I've disabled Freedome again. I couldn't get through to and as soon as I disabled Freedome the page loaded instantly...

    Does turning protection off and on again help? That works for me. 

  • LakshLaksh Posts: 4,444 Community Manager

    Hello @vms @Patman,


    As I checked on the issue, it might be the case that those sites are tracking your visit and it does not allow access if we block the tracking cookies. Freedome seems to be doing what is has been designed to do, block tracking cookies of websites that tries to track you. However, the website might not want to give content to the user as they force the tracking before giving the content. That might be the reason that the webpage loads when Freedome is turned off.

    In this case, you can try to turn off the Tracking protection and try again opening those sites. However, please be informed that in this case, Freedome is not protecting from trackers since Tracking Protection is off.

  • LakshLaksh Posts: 4,444 Community Manager

    Hi @seanchai,


    If you would like to try Freedome before purchasing the license, you may always try the trial version which is free for 14 days. Please download the installer from the link below for further testing:

  • PatmanPatman Posts: 12

    I turned tracking off but I still can't connect to

    Server not found

    Firefox can't find the server at

        Check the address for typing errors such as instead of
        If you are unable to load any pages, check your computer's network connection.
        If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.


    I clicked the retry button and the web page loaded, so I will leave it on and see what happens.

  • Thanks for the quick reply Laksh ...much think i will try the 14 day trial, at least that will put my mind at rest whether 'freedome' will work ok with windows 10...i read an earlier post about tracking cookies , and that makes a lot of sense , i have noticed that more and more sites want their cookies to be "allowed" before it lets you access the site .

    I will certainly give 'Freedome' another try as in itself i think its a great idea ....although as your answer to an earlier post says that some sites we would need to switch off freedome (or at least disarm freedome ) before we can get into certain sites defeats the purpose of 'Freedome ' ...does it not ?

    Thanks for your help Laksh .




    Good luck to all who are having probleMS with Freedome, Hope you get the problems cleared up soon.

  • I am having the same kind of connection issues. I am utilizing an Android 4.1.1, on a ZTE.
    My issue is connectivity while trying to play the game Hay Day. Freedome turns itself off after 2-10 minutes. I use Espoo, London, Germany, and East coast United States. It does the same on each one.
    Any and all assistance is greatly appreciated.
  • I still have Freedome turned OFF and I will not be renewing my subscription unless this has been fixed. The 'support' has been useless so far...

  • I never tried the 14 day trial of Freedome as i seem to remember that the the early days of my trial everything was fine and i had no issue with freedome , infact i wrote in various saying that it was a great idea ...and it is ...if it works ok .

    Patman have not had the service you paid for and if i was you, i would ask for a full refund or at least you should get a refund for the unused period of your subscription .

    Good Luck my friend .


    Gerry .

  • PatmanPatman Posts: 12

    Hi there,


    I'm still having the same problems with slow internet and unable to connect to web pages. As soon as I turn off Freedome the problem is gone. And so from now on, Freedome is also gone from my devices. Their support sucks.

  • Hi

    I started to use Freedome and get same problem. When Freedom is ON I cannot make the internet connection with any browser,and when its is OFF all browres work very good.

    My location is in Thailand and I want use IP from Espoo.

    My OS is Windows 10 and I use my laptop in WiFi network of the hotel.

    Oakla Speed Test get next values (without Freedome): ping 50 ms, 9,8 Mb/s download speed anh 0,9 Mb/s upload speed.

    I can use next browsers:

    Google Crome


    Windows Edge

    Are there anything to do?


  • PatmanPatman Posts: 12

    I have turned Freedome off and will be looking for a new VPN

This discussion has been closed.