Freedom Android App not working on tablet.

I've this android 4.2.2 tablet and installed the freedom app via google play store. If i tap the button/circle to activate vpn connection the button/circle rotates a few times and then stopps. No connection is beeing established. Nor do i get any error/log message. The first time using the app i checked at the poopup box that i trust this app and it may open up a vpn connection. What can i do to get freedom working on my tablet?

Comments

  • NiklasNiklas Posts: 31

    Have you tried reinstall the app on the tablet?

    If so was the problem exactly the same after?

     

    /Niklas

  • JaysonJayson Posts: 595

    Hello,

    Kindly try connect to a wifi(wireless LAN) then switch ON the F-Secure Freedome? Please let me know how it goes.

    Thanks.

    Best Regards,
    Jayson

  • w2k3noobw2k3noob Posts: 3

    No, i do not have deinstalled and reinstalled the app because i entered a coupon code giving me 180 days of free trial and i do not know if the coupon ist still valid or if the app would automatically remember my trial. I want to avoid the lost of this free trial.

     

    However the app got an update recently. But no changes in the behavior. Still it does not establish a vpn connection.

     

    @Jayson i establish a connection through my home wireless network first an the enable the freedom app to establish a vpn over my w-lan.

  • JaysonJayson Posts: 595

    Hi,

     

    We have released a new Freedome build last week, please logon to Google Play Store and upgrade the application.

     

    Thanks.


    Best Regards,
    Jayson

  • I just installed the app on my Android tablet (4.4.2) and I have exactly the same problem. Even rebooted, but no change.

     

    Ove S.

     

  • ChrissyChrissy Posts: 438

    Hi Ove!

     

    Is this issue still ongoing?  Let us know so we can investigate further :)

     

    // Chrissy

  • Actually I downgraded back to Android 4.3 (CyanogenMod 10.2) so now I have Freedome working just fine Smiley Happy

    Chrissy
  • I have a similar issue. The  "Freedome attemps to create a VPN connection" page never appears after installation so I never get chance to check box. .  I am running Android 4.4.4 on a Samsung Galaxy s4.  I have uninstalled and reinstalled app and it still won't start.  Reboot doesn't help either.  Any advice? Thanks

  • LakshLaksh Posts: 4,442 Community Manager

    Hi rwjack,

     

    You can check this article here for more information on this.

     

  • Tried all of that, still no luck.

This discussion has been closed.