installation failed



  • it gets worse


    i went to windows defender to enable it (because ive been very patient  and had enough now ) and it said something about unable to access specified paths or device or something likme that???

  • im gonna leave this page open and come back to this tomorrow, Thanks for trying guys (and just incase NikK is a Nicola) gals, i appreciate it, however i will reinstall the trusteer thing for my banking.


    maybe catch ya tommorrowSmiley Embarassed

  • NikKNikK Posts: 935 Rock Star

    For FSDIAG, try this:


    1. Right-click the link and select save target as, to save it somewhere on your disk (remember "where" you save it)

    2. Open a windows explorer and go to the download location you selected above

    3. Right-click the file and choose Extract all. Click Extract in the next window.

    4. Open the directory fsdiag, and then open the sub-directory fsdiag

    5. Double-click the file fsdiag.exe and follow the instructions


    ps. Nikk is more like a Nik Kershaw than a Nicola Smiley Wink

  • SimonSimon Posts: 2,653 Superuser

    @NikK wrote:
    ps. Nikk is more like a Nik Kershaw than a Nicola Smiley Wink


    Just don't start talking in Riddles.  (You're not actually Nik Kershaw, are you? Smiley LOL )


    Just to add to Nik's excellent instructions, the easiest download location is your Desktop. 


    I would also suggest running Windows Update again, as sometimes not all updates appear at once, especially if a machine hasn't been updated for a while.


    Sorry we've not come up with a solution so far.  There's obviously a) something stopping the installation, or b) a problem with the installer - and a lot of this is guesswork, as we can't see inside your PC!  Smiley Wink  Hopefully, if you can send an FSDIAG to F-Secure, they will respond quickly, and get you sorted.  :)



  • NikKNikK Posts: 935 Rock Star

    No, I'm closer to F-Secure headquarters than the UK. 

    No riddles, but I can go on until the sun goes down on me. Wouldn't it be good Smiley Wink


    And to add to Simon's advice: if avg tune up turnes out to be the problem, I suggest you post on their forum asap about the un-install problem.

  • I see the thread has been somewhat abandoned for awhile but we have pretty much the exact same problem. In first attemt to install it loads "normally" up to 99% and just says installation failed. Upon trying to re-install, it jumps to 70% bounces bit around those numbers and crashes at 99.

    It should be said that whenever we try to download the installer/uninstaller, windows locks it up becouse it´s "from another computer". That isnt problem tough, since the locking can be disabled from the properties.

    Ive tried everything suggested in this thread altough Avg or other virus-defence softwre apart from F-secure has never touched this comupter.

    This computer is quite old, still runs XP. Also this message and problem have been handeled by the users son up to this point, the person most likely responding from now on "is not an expert" on these issues. Please bear with her Smiley Tongue

  • SimonSimon Posts: 2,653 Superuser

    Try looking through this thread:


    The user had a similar situation, but unfortunately, none of our suggestions worked for him, and he had to get help from F-Secure, however, it might be worth trying what has been suggested in the thread, before contacting support.

  • snezzasnezza Posts: 2



    not going to pretend that i know as much as you do or even that this is going to work for you, but here's what i did.


    had same problem as mr madazz so tried everything suggested but to no avail, so enabled my in built admin account in Win7 and installed from there and it went through ok.


    Could this be the way ahead or is this going to lead me into trouble.



  • SimonSimon Posts: 2,653 Superuser
    I assume you mean the hidden 'super-admin' account? That's certainly worth a try. For those that need help with that, go here:
  • mgpmulmgpmul Posts: 7

    I have exactly the same problem as maddazz describes: "FS loads upto 70% then bounces between 94 & 84% before whizzing to 100% " installation failed ". I uninstalled previousley installed scanners (McAfee, AVG), I restarted several tiimes, checked for Windows updates, etc.


    I just tried the last suggestion, that is, to run the FS installer as 'super-admin'. Still: the same behavior, so still no FS installed.


    I am very interested in any other suggestestion. Besides, all this time my laptop is uprotected...worried....Smiley Sad

    (OS = Windows 7)

  • SimonSimon Posts: 2,653 Superuser
    I know it seems we keep asking the same question, but did you uninstall the previous AV products using their specific uninstallers, as linked to above?

    Just another suggestion, and I think Blackcat mentioned this elsewhere, but have you tried installing F-Secure in Safe Mode With Networking? Not sure if it will work, but otherwise, it's a support request to F-Secure I'm afraid. If you're concerned about being unprotected, you could install the trial version of Malwarebytes Pro and also enable Windows Defender (or MSE) in the interim, until this is sorted.
  • mgpmulmgpmul Posts: 7

    Yes, I uninstalled other AV programs (AVG, McAfee, F-secure (the failed one)) with the AntiVirusRemover.exe program that is advised by Blackcat  here (

    Sure, helpful program, thanks for that.


    Then, three restarts later, I installed F-secure again, being THE built in adminstrator user of Windows 7, in Safe mode with networking.

    Still, the same behavior, ending up in a failed installation (after about 45 minutes).




  • SimonSimon Posts: 2,653 Superuser
    Did you try in Safe Mode with Networking? Other than that, I'm out of ideas, sorry.

    There are two or three threads running with the same issues at the moment, so maybe having a look through those other threads might give you an idea of something you haven't tried yet. Otherwise, it's time for a support request. Smiley Sad
  • mgpmulmgpmul Posts: 7

    Yes, also in Safe mode with networking (I added this to my previous post as well, as I saw I forgot to add it first).

    As a next step, I'll try to issue a ticket via support.

  • SimonSimon Posts: 2,653 Superuser
    Good luck!
  • Hi another virgin customer, having problems with install. Completed first steps registered etc but when i click install button after naming device i just get a pop up saying error try again in a moment. Thats all nothing else nothing else. I have totally uninstalled virgin media security and still same problem. Any help before i cancel my virgin subscription and go to sky would be appreciated.
  • SimonSimon Posts: 2,653 Superuser
    I'm on my phone at the moment, so it's difficult to search the forums, but I seem to recall that we've had this one before, and it was something to do with the device naming. Sorry to be vague, but hopefully someone can find the thread / posts that relate to this.

    I have to say, though, that so many difficulties with installations doesn't look good on F-Secure, so I hope that they can find the time to post some solutions here soon.
  • snezzasnezza Posts: 2



    It may also be worth mentioning that i have also uninstalled the virgin media service manager. This is not necessary now and may interfere. VM doesn't prompt you to jettison this when getting rid of the VM security.

  • NikKNikK Posts: 935 Rock Star

    @Soddingannoyed wrote:
    Hi another virgin customer, having problems with install. Completed first steps registered etc but when i click install button after naming device i just get a pop up saying error try again in a moment.

    I think the thread Simon mentioned is this one:

    Unfortunately we never got any feedback if the problem was solved or not.

  • SimonSimon Posts: 2,653 Superuser
    That's a shame. I've bumped the thread so maybe someone will come back to it.

    But I seem to recall there was a thread in which an F-Secure Expert commented, and it was something to do with matching the device name. Maybe I've been here too long and dreamt it! Smiley Very Happy
  • i have windows xp professional version 2002 service pack 2  with 504 of ram. 2.39 GHz  2,40GHz


    i downloaded the program but it wont let me install.  it says my current version of windows is not supported,  on the supports page it doesnt state what service pack i need.

  • NikKNikK Posts: 935 Rock Star

    You need SP3 (Service Pack 3) What "version 2002" means I don't know. I guess you mean Office version.


    In case you haven't noticed: Microsoft is dropping its support and security updates for Windows XP in april 2014. So you might wanna get a newer PC. Just an advice.

  • SiltanenSiltanen Posts: 108 Former F-Secure Employee

    Hello All,


    To me it looks like there are a couple of different problems reported so far to this thread (and at least some have found a working solution already.)


    So - if there's still somebody there who hasn't been able to install F-Secure on their computer(s) - I'd advice to open a support ticket at:


    It will the best course of action at this point, as we'll be able to gather also logs from the affected computers to make sure we can avoid installation issues like these in the future.



  • MolaMola Posts: 3

    Hello.  I too am having continuing difficulties with the installation of F-Secure, necessitated by the (imposed) change over from VirginMedia.  I have been through the process and yesterday sought some help from a local IT expert, since my attempts to contact customer support have so far been useless - no response.  I hope that I shall now find that this method is indeed the quickest way of getting an answer, and resolving the problem.

    I am assured by the IT expert that the system has been installed, and is indeed running in the background.  However, every time I switch the machine on I am prompted to enter a subscription key, and this is repeatedly rejected - so I get the 'Installation failed' message.  My machine is the second in our household upon which we have been trying to install F-Secure. After considerable difficulty, my husband [the main account holder] has managed to install it successfully on his machine. We have 5 licences available, and so are using only 1 at present; and, as directed,  I have been using the same subscription key as he used when successful.

    Are there particular problems related to the registration/validation of more than one machine?  We are sure that we have followed the correct procedure, which has been time-consuming,so this is now becoming very tedious.  I look forward to a rapid response.

  • StephanStephan Posts: 351

    Hello Mola,


    Hope this response is rapid enough :)

    We're sorry you're having problems getting in touch with our customer care team.

    I can assure you, this is not the normal situation. We're currently very busy, due to the holiday season.


    Could you please visit the SAFE portal (
    Once you logged in, please click "install" next to Internet Security and follow the instructions, download and run the installation.


    There is no need for any subscription keys anymore, the portal will take care of all that stuff.


    Could you please let us know if this solved your issue?


    Best regards,

  • MolaMola Posts: 3

    Hello Stephan.  Thank you for your prompt response, but sadly I'm still in the same position, after following the instructions as advised: there seemed to be no problem with the download and installation (indeed, as I said before, it had appeared that I had in fact already succeeded in that).  But even after switching the machine off and re-starting it, still I am being reqested to type in a subscription key.

    Do you have more ideas about how I can eliminate that please?

  • NikKNikK Posts: 935 Rock Star

    When you download and install from the SAFE portal there should be no prompt for a subscription key! So something is wrong here.


    - I suggest you un-install the product from your machine using Windows Control Panel, Programs and Features.

    - Then run the Uninstallation Tool 

    - Read the PS section below

    - Reboot

    - Then log in to the SAFE portal and remove your machine from the list of installed devices. If it does not appear there, I guess you haven't installed through the SAFE portal (which would explain why it asks for a subscription key)

    - Then in the Internet Security section in the SAFE portal, click Install and follow the instructions.


    PS. Some customers coming from Virgin Media Security have had strange problems with F-Secures product because VMS haven't been completely removed for some reason. If you haven't already run the additional VMS removal tool, read this post under the heading "Removing Virgin Media Security".

    Give Kudos to say "thanks". Click "Accept as Solution" to inform others when your issue's been solved
    Need more help? Submit a Support Request or chat / call F-Secure support
  • MolaMola Posts: 3

    Thanks for trying, NikK.  We have already uninstalled and installed again - maybe we are indeed missing something, but it seems very strange that there have been no such problems with the installation onto my husband's machine.

    Right now the frustration levels are too high to attempt anything else!  And I would still appreciate a further response from Stephan too (presumably tomorrow) as I do think that the F-Secure customer support isn't great at the moment (and i do realise that there may be reasons for this); but I'm certainly not getting what I've paid for at the moment!


  • NikKNikK Posts: 935 Rock Star

    I see, but maybe you can answer these quick questions (your answers may help us help you better):


    When you log in to SAFE, do you see both your computers in "Your Devices" at the bottom of the page?

    Do you have different OS - Windows/Mac versions?

  • SimonSimon Posts: 2,653 Superuser

    Hi Mola,


    Just in case it gives us a clue, please could you briefly run through the difficulties your husband had installing FS on his machine?


    To all intents and purposes, it sounds like you have installed the stand alone Internet Security product, rather than using SAFE., but I wouldn't like to assume that for certain.


    My best advice would be to go back to square one.  When you feel less stressed about all of this, first, check Windows Updates for any pending updates, and allow those to install.  Then, I would advise that you once again download and run the Virgin Media uninstaller from here:  Once that is complete, reboot the machine, then run the F-Secure uininstaller from here:


    Once that's all done, log in to your F-Secure SAFE portal, and once again try to install Internet Security from there.  If you are already registered, through the Virgin Media link, then there should be no need to enter a license key, as it's all taken care of via the SAFE portal.


    I'm sorry if we are only suggesting what you have already tried, but as you say, something may have been missed, and going back to start from scratch is often the best way to solve issues such as this.

This discussion has been closed.