F-secure for mac: Cannot quit application

Options
kewpie
kewpie Posts: 3 Observer

F-secure version: 19.6 (61923)

macOS version: Sonoma 14.4.1

F-secure does not quit after clicking on the Quit command in the Menu bar. Keyboard shortcut (⌘Q) does not work either:

I still can see the F-secure icon in the status menus of the Menu bar

Even if I Force Quit the F-Secure process via the Activity Monitor, the process is immediately re-spawned.

I do not need the F-Secure app running all the time, so this behavior is extremely inconvenient.

Accepted Answer

  • CarolinaC
    CarolinaC Posts: 98 Moderator
    Answer ✓
    Options

    Hello @kewpie ,

    thank you for contacting us here on F-Secure Community Portal.

    Have you checked if the F-Secure app installed on your device is up to date? Have you also tried to reinstall the program and see if the problem is solved?

    If you haven't done so, I would like to ask you first to reinstall the program with our uninstallation tool for Mac :  https://www.f-secure.com/en/support/tools  . This tool will delete all the F-Secure files and errors. To reinstall it, simply login to your My F-Secure website and release the license for the device. Next click on Add device → My device → This PC → Download for Mac.

    If the problem persists after the reinstallation, I would like to ask you to create a diagnostic file that will help us determine the cause of the problem and find the best solution for it. As the diagnostic file is confidential, please send me the file by private message. I have also sent you instructions on how to create a diagnostic file via private message.

    I am looking forward to hearing from you.

    Best regards!

Product & Pricing Info