Freedome/VPN doesn't work with Tailscale on a Mac

Hirezz
Hirezz Posts: 1 New Member

I have been using both F-Secure Freedome/VPN and Tailscale for several years. Until recently I have been able to keep Tailscale running in the background while making a connection with Freedome.

I start and connect Freedome only when I really need it, which is perhaps once in a month. About 2 months ago I started noticing problems with Freedome. When a connection was made, I wasn't able to open websites, or a ssl warning was given. When this happened, I usually turned wifi off and on again, hoping that would correct possible underlaying dns/routing issues. Because of the problems I stopped using Freedome.

In a hindsight the problems started roughly when macOS 14 was made public.

A couple of days ago I had a need to fake my location to the US, and tried to use Freedome again, to no avail. I have known that Freedome doesn't work if another OpenVPN client is connected. Tailscale is using WireGuard, but when I closed Tailscale, Freedome started to work immediately.

Additionally, Freedome with an active connection prevents Tailscale from starting.

At this point I cannot be 100% certain that Freedome and Tailscale have worked correctly simultaneously, but because I have used both for so many years, I have to assume that there has not been any problems previously. One of the reasons I keep renewing my Freedome license is its reliability: it just works. Until now, obviously.

I think something changed a couple of months ago, likely in the MacOS, in F-Secure VPN, or in Tailscale.

I'm also linking this post to Tailscale's support, because Tailscale is the best thing after sliced bread, and I really hope you guys could figure out how to get both applications working together.

I'm using macOS Sonoma 14.1.2, Freedome 2.69.55.0, and Tailscale 1.54.1 (Mac App Store variant) on an M1 Pro cpu.

Accepted Answer

Product & Pricing Info