Version 3.5.0.x worst than ever

Options
OSX_rulez
OSX_rulez Posts: 27 Enthusiast

I really hoped the new release 3.5.0.9074 would solve all the (dis)connections problems already reported by me and other users, but it's not at all!

The app is disconnecting several times a day, sometimes even when I'm using the internet and this is very annoying especially if I'm for example sending a form. Or it is just stuck and nothing is loading, so it means you have not solved the previous servers issues!

When the app doesn't load the content, apparently the device is not correctly receiving the IP address from the VPN server, this is something I already reported. The connection in this case seems to be on, but nothing happens.

I'm seriously doubting that F-secure staff aroud the world is even using their own app, otherwise they should have solved by now...

Another problem with the latest version on iOS 17.1.x is AirDrop not working between an iPhone and a Mac on the same wi-fi when Freedome is active on the phone, and I'm pretty sure it worked previously.

So, if this is not solved definitively I won't renew my subscription (7 devices since many years) and for sure I' won't suggest it to my clients.

Don't tell me to uninstall, reinstall, check my settings or such unseful things. Is it possible to activate some kind of networking log in the app to record a session and send it to support when a problem arises? Thank you.

Accepted Answer

  • Firmy
    Firmy Posts: 1,778 Community Manager
    Answer ✓
    Options

    Hello @OSX_rulez

    Thank you for your cooperation.

    I've notified our team and provided them with the log files. They will conduct a thorough investigation into the issue, and once they've provided me with feedback, I'll ensure to keep you updated.

    We regret for any inconvenience this may have caused.

    Thank you for your patience and understanding. Wishing you a pleasant day ahead.

Answers

  • Firmy
    Firmy Posts: 1,778 Community Manager
    Options

    Hello @OSX_rulez

    Thank you for your post and feedback.

    To better assist you, could you please record a short video showcasing the problem along with the settings you are using? Additionally, generating a log file would provide valuable information for our investigation. I have sent you a private message with instructions; kindly share the details with us through that channel.

    Another problem with the latest version on iOS 17.1.x is AirDrop not working between an iPhone and a Mac on the same wi-fi when Freedome is active on the phone, and I'm pretty sure it worked previously.

    Have you added the network as trusted? If not, you can follow the instructions in this link: Marking a local WiFi network as trusted | Total | Latest | F-Secure User Guides.

    Your cooperation is much appreciated, and we will do our best to address and resolve the matter promptly.

    Thank you and have a good day.

  • OSX_rulez
    OSX_rulez Posts: 27 Enthusiast
    Options

    Hello @Firmy ,

    I will follow the instructions to send the log, I hope it contains enough data. I don't understand what kind of video should I record.

    AirDrop: I added my wi-fi as a trusted network, nothing changed. I noticed that setting was off, so I enabled it, because sometimes iOS ask to add the VPN again, as if it was removed previously (even if it's still active).

  • Nick889
    Nick889 Posts: 1 Observer
    Options

    I am having similar issues. F-Secure VPN had been working flawlessly for a long time, but around 1-2 months ago my connection started to time out and it has been the same ever since. My VPN doesn't visibly disconnect, but there is something wrong with the connection itself because websites time out most of the time. All I can do is reload the websites when this happens, and it can take several reloads before the website works normally again. For example I opened F-Secure website itself and tried to log in, but the connection timed out and forced me to reload browser and to try to log in again.

    I formatted my computer due to other reasons, but the problem persists even with fresh install, and changing to a different network doesn't help either. The problem vanishes when I disable F-Secure VPN. I didn't make any changes to my computer/network before problem appeared, so it kind of just came from thin air.

  • TheFlyingFinn
    TheFlyingFinn Posts: 1 Observer
    Options

    Long time happy user of Freedome but I now have the exact same issue since a few months back, I've already starting to disable Freedome during sessions when I absolutely don't want any dropped connection. I have uninstalled and reinstalled but no change. It has now come to the point that I have cancelled my auto-renewal of the license and I will not renew if this is not fixed soon. Also, my network (1Gbit) works perfectly well when I disable Freedome.

  • NatV
    NatV Posts: 19 Enthusiast
    Options

    I have the same problem on version 2.69.35.0.

    After change to a new windows PC and reinstallation of F-secure VPN I had to create an F-secure account and convert my subscription code. Since then it became unworkable and I had to turn the VPN off in order to be able to use the internet at all. Incredibly long load times, websites not loading at all due to time-out, loss of internet connection etc.

    I have been a very happy user for many years, but the last couple of months were cumbersome.

    My subscription ends in a few months, and I'm currently scanning the market for alternatives. :-(((

  • nizze
    nizze Posts: 1 Observer
    Options

    I've turned off freedome now because of all the trouble with continuos disconnections.

  • eThor243
    eThor243 Posts: 12 Enthusiast
    Options

    I do have the same problem with all the devices in our house : 3 phones (Android) and 3pc w10 and w11.

    Each time some really long times while using all sorts of programs, from Instagram to Steam, onedrive, web surfing... All sorts of things.

    What is going on??????

  • OSX_rulez
    OSX_rulez Posts: 27 Enthusiast
    Options


    Hello, given that I haven't received any kind of reply from the support after sending many logs and the only thing that mitigated the different issues was to switch from IKEv2 to IKEv2 (to fix the AirDrop bug), but all the other problems have not been solved, I won't renew my subscription which is going to expire these days and will buy another VPN service. I'm very disappointed.

Product & Pricing Info