Freedome not working in Türkiye

Options
Junglelandfi
Junglelandfi Posts: 4 Explorer
edited January 3 in F-Secure VPN

Hi,

I’m in Türkiye, using a Vodafone SIM-card in a wifi-router (WAN IP-address xxx.xxx.xx.xxx). F-Secure Freedome version 3.4.1.8956 on an iPad Air (4. Gen) using iPadOS 16.5.1 does not connect.

Freedome gives an error message (in Finnish) ”VPN-palvelinta ei löytynyt” (VPN-server not found). I’ve tried Finland and Sweden, both give the same error message.

Is there a problem with your service, or is this some Turkish sensorship in action?

/Jari


Edit: PII removed

Accepted Answer

  • Firmy
    Firmy Posts: 1,755 Community Manager
    Answer ✓
    Options

    Hello @Junglelandfi

    Thank you for your post.

    I kindly ask you not to share personal information in this public forum to ensure the protection of your identity. I have taken the liberty of removing your information for your own safety. If you'd like to review the community guidelines, please follow this link: https://community.f-secure.com/en/discussion/122422/f-secure-community-user-guidelines#latest

    Regarding your post, it seems that you're facing a regional issue specific to Turkey. It's possible that there might be an issue with your Internet Service Provider (ISP) when using a VPN on their network. I suggest reaching out to your ISP directly to inquire about this matter.

    Thank you for your understanding, and I wish you a pleasant day.

Answers

  • Junglelandfi
    Junglelandfi Posts: 4 Explorer
    Options

    Thank you for commenting. I can confirm that operator restrictions are the reason. Thus, I can not recommend Vodafone TR SIM cards for anyone travelling in Turkiye. Turkcell SIM card works as expected.

This discussion has been closed.
Product & Pricing Info