F-Secure VPN breaks Internet browsing on M1 MAC running 13.3.1(a)

Sammyishome
Sammyishome Posts: 1 New Member
edited December 2023 in F-Secure VPN

F-Secure VPN breaks Internet browsing on M1 MAC running 13.3.1(a), tries using Firefox, safari, chrome, and no luck.

i also tried different connections (WIFI, 5G) without success.

I also changed the VPN protocol.

Tagged:

Accepted Answer

  • Firmy
    Firmy Posts: 1,619 Community Manager
    Answer ✓

    Hello @Sammyishome

    Welcome to the F-Secure Community. Thank you for your post.

    Could you please provide more information about how F-Secure VPN is affecting your internet browsing? Are you experiencing a complete loss of internet connectivity, or is it limited to specific websites when connected to Privacy VPN? Could you also let me know which server you are currently connected to on Privacy VPN and the version of F-Secure Total you are using?

    Have you tried changing the server location or disabling the tracking protection feature? It's worth noting that due to the prevalence of encrypted communications (HTTPS/TLS/SSL) on many websites and services, Privacy VPN may face limitations in fully decrypting the addresses of linked content. This can sometimes make it difficult to accurately differentiate between tracking cookies and legitimate content, resulting in slow page loading times or missing content on certain webpages.

    To help you troubleshoot the issue, here are some helpful links:

    https://community.f-secure.com/vpn-en/kb/articles/5114-why-does-my-internet-connection-slow-down-with-freedome

    https://community.f-secure.com/vpn-en/kb/articles/6115-with-f-secure-freedome-vpn-on-the-internet-connection-is-very-slow-on-my-computer

    Please feel free to reach out if you need further assistance. We're here to help!

    Thank you, and have a great day.

Answers

This discussion has been closed.
Product & Pricing Info